Compass Fail Issue

Everything works just fine,
Pixhawk : Orange Cube
GPS : Here3
Radio : Herelink
As soon as I arm the copter and try to take off , Yaw spins CCW speed is high.
I have done compass calibration. But no luck. Copter is spinning CCW at a high speed when I increase throttle to take off.
Above image is the auto analysis of flight log
Tried to disable onboard compass but as soon as I write those parameters I observed gps 3D fix became an issue.
Please help
Thanks in advance :blush:

Please read the Ardupilot Wiki.
1: Without posting a .bin file from the flight controller we can only guess at what is causing your problem. (in the Wiki)
2: You first attempt at liftoff should be in Stabilise, not a guided mode using GPS (in the Wiki)

So my guess is you have the props on wrong or the motor directions wrong or the motor order wrong.

Copter flew well actually
I went out in the open did compass calibration and it worked, I did RTL too and it worked properly.
Strangely when I again powered the copter on the rooftop of the building there was a msg on the screen compass inconsistent.
I believe itโ€™s because of magnetic interference in the building, new sensors are sensitive.