Compass issues - the dreaded toilet bowl!

(Mathew Herbert) #1

Hi all I have a bit of a head scratcher (at least to me).

We operate a large octocopter that we have been running with Cube black and the spektreworks carrier board with a Here GPS for sometime and haven’t had any issues with the compass up to this point. we recently updated to Copter 3.6.10 and now we have a weird intermittent compass issue that causes the dreaded toilet bowl.
We calibrated the Here compass (both 1 and 2) both passed no issues and and flew number of successful flights we then had a toilet bowl which lead to a crash.
We fixed the damage and it flew fine a few time then we had the problem resurface. However it is now more persistent.
To start with I turned off the internal compass (number 2) and still the issue persisted. I then turned off compass 1 and while mission planner is showing the error “bad compass health” the aircraft flys fine once a 3d fix is achieved.
So I started a process of elimination initially suspecting that it was the Here unit that was faulty (it was one of the first i ever bought and it has had a hard life) so I put a Here2 on and ran a compass cal (which was successful). Here is the kicker I got the same behavior including the deactivation of compass 1.
I have uploaded the initial log from my flight today where the issue is present while running the Here 1.
Any input would be great as this one has me stumped!00000218.BIN (2.5 MB)

(Justin Leamon) #2

Ive had a nearly identical issue on 2 of our multirotors that were running 3.6.10. The compass direction would rotate 180deg at random times. Would fly perfect for 15 flights or so then not so perfect. Havnt had time to fully resolve. Thought it might have been an issue with on old version of qgc overriding parameters. It hasnt happened using mission planner. Pretty sure its not hardware related.

1 Like
(Mathew Herbert) #3

We are using the latest version of mission planner but it sounds very similar.

#4

Is there a reason that you are not setting to parameters as per the Service Bulletin?

the log shows a Here 1, is that correct? and it is showing the orientation is out by 180 degrees.

Photo of the mounting?

(Mathew Herbert) #5

both the cube and the here are in the normal orientation with both arrows pointing toward the from f the aircraft (as they have since i got the aircraft airborne at the start of 2018)

.
I had not changed the parameters for the service builtin as they system was produced a full year before the Cubes that were meant to be effected.
I have now upgraded the firmware to 3.6.11 and enabled the parameters in the service bulitin and I am not getting any new warnings.

#6

Can you send a log with the Here2?

(Mathew Herbert) #7

Thanks Philip.
Please find all our logs for our day of testing with both the Here and Here2 in a couple of different configs.
00000222.BIN (1.7 MB)
00000220.BIN (3.1 MB)
00000219.BIN (2.0 MB)

#8

@jschall @sidbh @Michael_Oborne

(Michael Oborne) #9

the air frame suffers from alot of magnetic interferance

the sqrt lines should be somewhat flat lines. or vary maybe ±50. MAG 1 seems happy(ish), but the others are just getting to much throttle based interference.

(Michael Oborne) #10

you could try a http://ardupilot.org/copter/docs/common-compass-setup-advanced.html#compassmot-compensation-for-interference-from-the-power-wires-escs-and-motors

but this is really just hiding a problem that would be better to try resolve with cable twists/cable routing changes

(Mathew Herbert) #11

Hi Michael,

Thanks for the above but its when I use compass one that i get the issue. I can completely understand that the other two would have issues given the size of the machine but its when I take compass one out of the loop that I am getting stable flight and when it is turned on I get toilet bowling.

Not to mention this is not a new aircraft and has flown in this configuration successfully for almost a year before the issues have shown themselves.

I will do a compass mot after I do an initial test on 3.6.11 (regardless of what behavior occurs) but I am very skeptical about this being the actual problem.

Given what you are seeing in the log could it be a hardware failure somewhere on the carrier board allowing/creating noise that wasn’t there before?

(Michael Oborne) #12

Make sure that the front of the GPS is pointing forwards as well. Toilet bowling is a sign of bad yaw. Which could be a problem with the physical alightment issue as well with the external sensor

(Mathew Herbert) #13

Everything is aligned to the front (at least within the 0.5 of a degree that my Mark 1 eyeball can achieve). Again the unit has been flying on this setup fine for about a year now and has only recently begun to misbehave.
I have tried both the original Here and a brand new Here 2 and got the same result replicated in both setups.
When i put the Here2 onto the system i double checked alignment as part of our standard procedure. i also used a brand new cable.
The constants are the frame, the motors, esc’s, Kore carrier board and the cube itself. I have just updated to the latest firmeware and i will test on that to confirm its not a firmware issue.

(Mathew Herbert) #14

I have plenty of logs of when this behavior wasn’t present on this setup and I am happy more than happy to provide them for comparison but they are larger than 4mb which is the limit for this forum so please see bellow a link to a drive folder with all of our most recent logs along with some from further back where the behavior was not present.
https://drive.google.com/drive/folders/1HDShFcJ9DIizL3PvcVVM5ZdC3MWl89gv?usp=sharing

1 Like
#15

Any chance that an arm is twisted?

(Mathew Herbert) #16

No all arms are in good shape and the behavior is only present in Loiter & Pos hold Not in Alt mode.