Connect via QGC/MP to Herelink


I know that cross-posting in different forums is bad, I asked already on QGC Github ( for this. I am not sure, what the Problem is. But I think it could be also a problem with the remote hardware.

I am trying to connect from my linux machine to the herelink remote (like in this guide: with QGC. Meanwhile I tried it also from a Windows 10 machine with Mission Planner.

In both cases, I cannot connect to the remote and I also get no feedback what did happen. In the console there is no information about this and the apps are also not showing any information.
At the current stage, I have no flight-controller or some hardware connected to the remote.

Maybe you have some tips for me.

does QGC work on the herelink? does it connect display video etc?
also did you enable video sharing?

The QGC App starts and in the past I did some flights with it. Currently I haven’t connected any airborne hardware. Should I?
Video sharing is enabled.

Currently I haven’t connected any airborne hardware.

yes. no mavlink data will be sent if you dont have something valid at the other end.

Problem is solved by connecting airborne hardware as well as updating all firmwares.
Now everything works like charm!

Thank you.