Copter: onboard mag calibration does not start if HereFlow is used

(Lmd93) #1

Hi, I am trying to use hereflow for my quadcopter on either the Cube Purple or Cube Purple. Initially I went with firmware ArduCopter version 3.6.10 (stable). However in the full parameter list on Mission Planner, the param ‘FLOW_TYPE’ is missing so I could not enable the hereflow.

So I tried firmware ArduCopter 3.7 (latest), which I was able to get the hereflow working. However, when I tried to run the onboard mag calibration, nothing happens as shown below. I tried to calibrate my compass on QGroundControl as well but same thing happened, which is nothing.

I tried on both cubes and there isn’t any errors. Do anyone know why is the param ‘FLOW_TYPE’ missing in 3.6.10? Or why do the mag calibration not work for 3.7?

The mag calibration process just hangs or nothing happens when I start the calibration.
image

#2

Calibrate it first then add the flow. Or calibrate it on 3.6.10 then update… updating doesn’t remove the calibration.

Cube purple doesn’t have the extra IMU’s, so no worries about the service bulletin

If that works, we can raise an issue to look into the problem

(Lmd93) #3

Hi Philip, I tried your way of calibrating on 3.6.10 before updating to 3.7. When I tried to arm on 3.7 firmware, I received ‘bad compass health error’, and I checked that the compass was not giving off any reading since mx, my, mz and mag_field are constantly 0.

I was able to arm without any error on 3.6.10, however hereflow does not work since the FLOW_TYPE param is missing.

#4

Ok, try calibration on 3.7 (4.0) before adding the flow.

Thanks for trying this out!

(Lmd93) #5

The mag calibration can’t even run on arducopter 3.7. When I click start on Mission planner, nothing happens. The calibration don’t even start.

#6

With or without the flow connected?

(Lmd93) #7

Both with and without. As long as I am on 3.7 the calibration process doesn’t work.

(Ian ) #8

Have you tried the beta mission planner ? Of that does not work try downloading one of the older daily builds of 3.7 from July time.

Hereflow support was not added until current master 3.7/4.0 so that’s why you need to use it.

But try an older daily build for a stable one with the Purple Mag. Iv found June and July ones have been more stable than some of the later daily ones.

#9

I’m a bit confused… the topic starts with compass calibration not working when the HereFlow is connected…

Which would indicate that you think HereFlow has something to do with this…

So really, this is nothing to do with HereFlow?

(Lmd93) #10

yea, initially I thought that the compass calibration could not start when using the hereflow, but I realised that even after I disconnect the hereflow, the calibration still do not start.

anyway i have since switched to cube black for now. but i will try it on the cube purple when i have the chance. will update soon. thanks

1 Like