Crash Flight After Loiter Switch

Hey Everybody,

Here is a Log File from my last flight with Cube Orange and Here 3 Compass.
After a few minutes in Auto-Mode (Survey) i Switches to Loiter in this Moment the Drone turn around the YAW Axis and came down in 4 sec.
Can anybody give me some help? I don´t find the reason for this.


I can´t upload the Log, it is to Big.
Is here anybody who will have a Look at this file? Than i will send via E-Mail.


use gdrive or wetransfer to uptload your file

Hi all,

i have uploaded the Crash Files to Google Drive.

Here is the Link to the Folder.

Thanks for your help.

Crash Log – Google Drive

Your copter had already lost control moment before you switched to loiter. As you can see the desired attitude control.

At the same time there was a very large current draw.

The RCOUT C9 and C10 went to maximum and minimum. One of the motor may stopped spinning and its opposite tried to recover the thrust lost.

You may check your ESC or motor on your motor1 and motor2.

Hi Alvin,

Thanks for your help so far. How can i check the DSHOT ESC?
And is there a possibility to check the Motors?


Can you try if they still spin? By the Mission Planner > Motor test page

Hi Alvin,

Yes i tried it yesterday. All Motors runs normally. After this Test i calibrated all values new.
Than i tried a Test Flight. Started the Copter and hovering for 10 min above Ground (5m) for 10 min. All seems normally. Than i planned a survey in 60m above Ground. In the flight up to 60m the Copter turns ~90 deg. to the Left in Yaw Axis and back. And some seconds later he comes down and crashed again.

I don´t know what´s the failure.

Thanks for your help!


In the Link from Yesterday are the new Crash Logs for your Information.

Thanks a lot.


Some years ago I had a simliar problem, and was a short on the ESC cables that start to open with an very sharp edge of the carbon fiber arms. So some moments in the air, the cables touch the fiber carbon and went down.

As alvin say before, there was a large current draw in a very small moment, that coudl be a short.

I recomend to look your wires, near to sharper edges.



Thanks for your Input. I will check all Wires and put some new Motors and a new Dshot in the Frame. I won´t get this anymore. I`l hope it runs after this.



i can´t find any issue at the wires.


Do continuity test for all your GPS and rx wires and while checking make them little bit move so that u get confirmed is there any loose connection or not //hope this could fix u