Crash Solex on Herelink

Goodmorning everyone

this morning I did a few acres on an automatic mission with Herelink and Solex crashed 6 times.
The problem is not the crash (let’s say it is the minor problem) only that every time I reset it, I lose the data and references of the flight mission and for example I cannot manage a “resume” for battery change, etc.
Do you have any news about it?
thank you

P.S. I am seriously thinking of returning to QGC even though Mode 3 piloting is not implemented

Maybe new updates may help

Did you terminate the QGC running in background?
Also, can you share a screenshot of when Solex crash?

thanks for the answers … the release is the latest available and unfortunately I could not take screenshots as I was in flight. The Solex app closed about 6 times during a 40-minute flight mission set up with the Solex Mission. (detail: Solex crashes with Mission)
The good thing is that the UAV has continued the mission … the bad thing is that if the application crashes even once, I lose the “resume mission” references (pop-up on screen) for change battery and this is really a problem. I no longer know where to start the mission again when the battery is exhausted; I have to redo the entire mission plan eliminating the part already done (and for example on 30/40 hectares it is really difficult to keep track in mind)

Also … I bought Solex Mission but it runs on tablet … is it possible to run it on Windows (laptop) without using an Android emulator? I downloaded the Github but I didn’t understand much about what to install on the PC

thank you… :slight_smile:

As you said it had happened 6 times, looks like this issue always happens?
Can you tell whether there is any pattern to trigger this? Was the unit overheat or something? Did any error message pop out or it just close itself?

You may also generate a bug report to record the problem, so that we could understand it better

Hi Alvin … even if with a little delay I wanted to thank you for the
answer and I want to explain better why even today it happened about 10 times in a flight

Solex has no problems. It rarely crashes when used only for piloted flight

Problems arise when a mission is generated and especially when changing batteries on UAV (“resume” function) and I do it this way

I state that for simplicity I prepare the mission on Mission Planner because on the 5 'display it is a madness

  1. I prepare mission on MP
  2. I import into the Solex Missions folder on Herelink
  3. Import and generate the Terrain Follow from the Solex app (because MP doesn’t manage it for me)
  4. I start mission
  5. go flight

so far everything ok

then the app often crashes if used in this condition (i.e. while managing a mission)

other important problem…

if I have a mission that involves changing batteries, when the app crashes I no longer have the option of Resume Mission (the message inviting you to resume the mission no longer appears) and therefore I no longer know how far I have come

am I doing something wrong? you like
to manage automatic missions with Follow Terrain easily and not on the Herelink display? Or rather … do you happen to crash several times during a mission?

thank you

Most of the functions on Solex are inaccessible unless you have a autopilot connected.
Also, if I recall correctly the missions in ardupilot system are saved in the autopilot. GCSs are just read-edit-save the mission but not real time editing.

I guess your connection between Solex and autopilot was broken because of the battery change. Then the Solex crashed because you tried to resume (access the mission) before autopilot had fully reconnected.

You may try to go back to the front page of Solex after you have changed the battery. Then reconnect after the autopilot booted again.

Yesterday we had solex start crashing during flight on 2 seperate systems that have never had issues before. Maybe 4 or 5 solex crashes over an hour and a half of flight time between the two. Neither have been updated recently or really had any changes done hardware or software wise. With the exception today was the first time we used a common wifi network for streaming telemetry data to a laptop, rather than connecting directly to the herelinks hotspot.

QGC was never opened at any point, the crash didn’t cause a safety issue yet (sticks still worked to pilot the drone) but is obviously very concerning and we need to figure out what the cause is. I also saw some odd behavior in solex itself when once during a guided mission it suddenly was reporting the distance from launch was completely wrong for about 30 seconds and then it was suddenly correct again.

We had the app crash both in manual (loiter) flight and in guided mode (commanded from an onboard companion computer).

I also noticed (after the last solex crash and we decided to not fly anymore) the connection seemed unstable while on the ground and nearby. The signal strength Icon in the herelinks notification bar was jumping between full, half, and no signal in quick succession. The herelink settings menu looked to indicate a good connection -65dB or so 16,000kbs uplink bandwidth during this but sometimes looked to freeze for a second or two every now and then. I am not sure how much weight to put on that little icon, maybe it always did that and I didn’t notice?

Both of these drones have done multiple ~1 hour long flights without an issue like this before.

This is a lot to unpack with a lot of variables, I will need to go back out and try several different scenarios to Isolate the problem better.

I will figure out what firmware version they are running when I go back to the lab.