CUBE BLACK crashed AC 3.6.7 firmware( hexacopter)

#1

running arducopter 3.6.7 chibios with latest cube black had crashed today during the loiter mode .


log file linked into the google drive,please find

https://drive.google.com/drive/folders/1uC51RJ-pTBc_u7buZJb_Tpr8nHClndji

please any one look at the log and guide me what could be the problem caused?

#2

Looks like it was switched to Stabilize just before the crash.
IMU seems to be acting weird just before the switch to Loiter :confused:
Is there a video of the flight ?

#3

No video, we try to recover it in stablize from loiter mode but couldn’t have control

#4

As seen from the log IMU failure is the cause. Could you tell more about the build? Have you disabled IMU? What is the powering source?
Figure_1-3

#5

I have sent you a PM, you have unfortunately suffered an IMU failure. I am discussing with our team as to how to ensure this cannot cause a crash in the future. Something was seriously wrong even before takeoff, as only one barometer, and two IMU’s were present at takeoff. Under these circumstances, I would prefer that it would not let you take off in the first place.

1 Like
#6

according to the logs, the L3GD20 and the LSM303D, and the second Barometer were missing at takeoff.

Once I have the hardware, I can investigate exactly why this could happen.

#7

It’s hardware issue or arducopter firmware issue. How should I know before takeoff all three barometer and IMU are working to prevent next future crash like this

#8

Arming checks are disabled in log. Enable it to prevent a future crash.
ARMING_CHECK 0.000000

#9

OK thank you I will enable it

#10

Arming check will prevent takeoff in this scenario. It won’t solve the Hardware issue. Contact @philip so he can investigate further.

#11

We have bought 10 numbers of cube black with here 2 will it be same like this?

#12

Can you please look at the parameters of each of them, and tell me what the
INS_ACC_ID =
INS_ACC2_ID =
INS_ACC3_ID =

can you let me know if any are 0?

#13

3 is zero. I’m checking from his bin file.

INS_ACC_ID =1442082.000000
INS_ACC2_ID =1442826.000000
INS_ACC3_ID =0

#14

Let me check and reply soon

#15

I mean on his other 9

#16

I checked 6cubes there is no zero value in INS_ACC_ID for all 3 values expect crashed one. Uploading: IMG_20190416_232314.jpg… Uploading: IMG_20190416_232221.jpg…
There is only one IMU value available and EKF_IMU Mask value is 1.
Other 2 IMU value is zero.

1 Like
#17

Pictures didnt get uploaded. keep them in a new line without additional text.

#18

1 Like
#19

Can you please send the cube black serial number found in the messages tab? And the serial number on the base of the cube?
(Of the one with only one IMU)

#20

IMG_20190417_112214