Cube Black not detecting and can't upload firmware

I have cube black and has Arducopter firmware and was trying to upload beta 4.0.4 rc4 which is released todays.
Unknownly I went legacy firmware upload page in MP and that too firmware upload cube showing now as Legacy FMU and its not booting at all .trying upload different firmware not at all worked keep on saying not detected board type.
MP asked board type and I have choosed pixhawk/cube no MP couldn’t detect board type so firmware upload failed.

I have choosed custom firmwrae method also but no luck to work .

Please any one help me to recover my pixhawk cube.

Have you tried flashing it with rover or plane ?

Also make sure you are using the latest Mission planner and I’d suggest using the beta version. You can get this by clicking get beta updates on the help page.

Yes I was trying with latest beta MP only and also tried to flash rover and plane both of beta version also no method helps .

change or put SD Card in Cube and try again

Change new ad card also no result.

check from your PC driver

Latest beta MP is not resolving this problem.problem solved now MP version is. 1.3.73 build 1.3.7539.2569.

SD card has nothing to do with firmware btw…

Is the Cube detected in Device Manager?

Now problem solved I have tried with different MP version