Cube Blue GPS issue

The GPS keeps dropping to 0 then back up 12, boots up fine, no other issues but that. One day it was working fine, next day it was not. Tried a new Here2 GPS, same issue, tried switching from GPS1 to CAN, same issue.
Sometimes it goes in cycles, like every yellow 12 flashes then blue, when in CAN, drops to 0 sats, then back to yellow and 12 sats. Other times it’s random, will go minutes without doing it then it happens.
Also, it does not happen when powered via USB, only happens when battery powered. Fresh batteries, 8s 22000, using Mauch power sensors, Hub X2, and 14S BEC. Any help will be great.

2020-12-16 12-42-03.bin (628 KB)

It sounds like external influence on the power rail as it’s doing it on both serial and can on different modules.

I’ll have a look at the log shortly too but has to power related issue , can you post some pics of the setup

Hey, too funny, I was just watching your video on setting up the CAN GPS when I was installing it as a reference, nice job!
As for pictures I don’t have any of the internals but here is how it is laid out.
Two Mauch power sensors connected to Hub X2. Hub X2 connected to Mauch 14S BEC. BEC connected to power 1 and power 2 on Pixhawk. Power for 14s BEC connected directly to PDB. Separate Mauch 5.3v BEC connected directly to PDB going to Pixhawk rail.

Any help would be great, thanks.

We had the very same issue and followed the same line you are going down. The way we solved it is with a second GPS. BTW it happens on our cube blacks periodically too (happened Friday) so we mounted dual Here2 GPS antennas to every drone we operate. I hope this helps. As far as I know there is no fix for it other than a second antenna.