Cube blue incompatible with IST8308 compass (Ardupilot)

It looks like the cube blue is not compatible with the IST8308. I connected three different units of the mRo GPS u-Blox Neo-M8N IST8308 to two cube blues using ardupilot 4.0.7 and the IST8308 I2C compasses were not recognized. I made sure that the COMPASS_TYPEMASK parameter was set to 0 and checked the connections so I’m pretty sure there was no connection or parameter mistake (I also connected a unit of the older mRo GPS Dual compass and it worked as expected). I tried the three GPS units with other mRo x2.1 and cube orange flight controllers, and the compasses were detected so I concluded it must be some compatibility issue with the cube blue.
Can anyone witha cube blue and a IST8308 I2C compass confirm this? I’m using arducopter 4.0.7

I think this PR will fix it:

Here is a 4.0.7 copter build with that patch applied for you to test:
please comment on the PR when you have tested so we can confirm if it works.
Cheers, Tridge

Looks like it works, thank you very much, I can’t believe you fixed it that fast. I’ll let you know when I fly it.