Cube carrier board damaged

Quad crash due to a radio fail-safe issue , I think , frame had minor damage but the Pixhawk 2.1 cube orange didn’t power up after crash , when I open the pixhawk case I found that carrier board had a small crack near the power ports and I Think that’s my problem, but is there any way to find out if the orange cube itself is damaged unless it is powered from the carrier board, I have found ADS-B carrier boards for around $123, anyone had this problem or any help is appreciated

Try powering up through usb port… i.e. usb connected to cube through laptop… The essential power required to power up the cube orange will be through the same usb port. It should connect to MP or QGC and later on u may check the params and calibrations in detail.
Yasir Khizar

Just make sure you have it on the carrier when you connect as I have found I could not correct worn out it being on the carrier at all.

I have tried usb to connect it while on carrier board but didn’t see any lights , And don’t see it on com ports on MP , should I remove it from the board and try to connect

I did try to power thur USB port on cube but no lights and could not connect to MP , not on com port, should I remove cube from carrier board and try usb again , will it power up without carrier board

Which one did u try? One port is on the cube whereas other is on the standard board? I think u better try to power it with the usb port on the cube rather than from the usb port of standard carrier board. I hope some expert i.e. designer (@philip) may suggest u how to rectify it if u r unable to power it via usb port of cube.
Yasir Khizar

I’ve had a crash on the cube, which slightly bent the carrier board, also no power. Turned out where it bends most, is where the Power selection daughter module is soldered on and the solder points were cracked (hardly visible, but no continuity). Re-soldered the spots around the Power Selection Module and all worked fine again. Needless to say that it should carefully be considered weather such a repaired board can be trusted.
The design seems mechanically a bit weak in that regard. But in my case it happened to act like a FS and instantly cut power, which was desirable in that situation.

I tried to power the cube by itself once without being connected to carrier board and it will not power that way. It has to be on a carrier board to power on.

You can power the cube from USB, Power 1 and Power 2 and the servo line.

The Cube needs to be on the carrier to work.

Also note if you have damaged the regulator on the Carrier the cube still won’t work.

Really you need a working carrier to test this.

Can you post some pictures of the cracks so we can see where the damage is.

I thinking about getting a new carrier board , and used my cube but want to know if the cube is still functioning , because I may need to buy a complete carrier board with cube,
That’s where I am , if I post a picture of the damaged board would that help

Here are some pics

I removed carrier board from case and attached the cube and place pressure with my finger on bottom of board and top of cube I was able to get it to power on with the USB plugged into the cube as long as I hold it firmly with my fingers , maybe the cube isn’t damaged just the board, I’m hoping anyway

That’s a very big crash to do that much damage.

I would not be using the cube regardless as the force needed to do that is extreme imo.

It’s may be fine but that’s some force to damage the carrier like that, it’s right through the power area so at minimum you will need to test on a new board.