Cube Carrier board development

#1

Hello, we bought Cube with original carrier board for development purposes, and we are into developing one that fits our needs right now. However we ran into some issues:

  1. Cube in ORIGINAL CB, after plugging USB into it blinks green and then only red/orange with some pulsing. A new device in windows manager appears, however we are unable to open com port to communicate with it.

  2. On custom CB, Cube is being dead solid green with no pulsing whatsoever. I raised slightly VCC 5V (63, 65 pin of cube) (from around 4,88V to above 5V) and orange LED (one) started to blink (all the time). After connecting USB to cube, no device appears in windows manager.

For the cube connector, we only applied power to the main pins (65, 63) and the GND of course. We started to dig into schematic of original CB, we were trying to pull down brick_valid, power VUSB, or play with VUSB_valid but this results in no change in Cube behaviour whatsoever.
Replugiing cube into the original CB gives same result as in pt. 1 so we dont think we could damage it anyhow.

My question is - what we are missing in both cases? Why on custom CB powered cube behaves differently than on original carrier board, if USB is plugged directly into the cube?

#2

Vbus is not connected on the cube except via the carrier board.
The cube does no power management at all. This is by design.
For USB to function, you must connect both vbus lines to power in.

The PSM module is not an optional extra, it is a key component in the design

Regarding item one, check you have latest drivers installed on mission planner by doing a clean install via the MSI.

#3

Thank you for your response Phillip,

But does this mean, that Cube cannot work (without USB connection) just by these 65,63 + !Brick_valid? Is there any “startup” guide or piece of documentation that specifies bare minimum to get things going without redundant power, etc? Our idea was to power cube with single source, use uart to talk to it, and connect to the outgoing headers the basic stuff like PWM’s for ESC and all signals from the 80p header we might need. We have plenty of pixhawk controlles going in house, but cube got us confused at day 1st of “usage”.

#4

We offer consultation on design matters.

I published a fully proven design for free.

Yes it can be used with a very minimal setup if the full application has been fully considered.

If you want free help, post your schematics here and I will look over them.

#5

So yeah, im posting Cube part for consideration. As you can see, really not much. 5V is working just fine (checked) Rest of the schematic is just attaching cube to CM3 module and rest of the signals to pin header. I didn’t attached VDD_BRICK_VALID to GND, so i wired it later, but observe no difference in Cube light pattern (solid green + flashing single orange). We didn’t wire up USB because we didn’t considered having USB on our platform, so basically if we can do all the stuff via uart or in original CB, we are fine.

About reinstalling - did not help. I installed latest Mission Planner on machine where this was never installed, so it had to install all necessary drivers. Device appeared in manager (F4), but it was impossible to connect to the module. We are considering sending it back for replacement or trying flashing STM’s inside.

1 Like
#6

Screenshot of ports showing on windows with it connected?

#7

Hello, I hope you mean this.
When i select COM22 in MP, it would still not connect.

#8

Looks like old drivers to me…

Reload mission planner with the latest MSI, not via the upgrade button.

Remove your current installation

#9

As i mentioned,
I never had MP on my machine and yesterday i downloaded .msi pack from here
http://firmware.ardupilot.org/Tools/MissionPlanner/ (with adnotation latest).
I dont think I can go more recent than that. Never had any drivers for pixhawk before.

What’s more, we tried this on 4pc including linux machine, no luck what so ever.

#10

Ok i managed somehow to upload something to the cube, and it is now connecting to MP.

Now to the Carrier board, i got this constant green light around the base, and flashing amber if VCC = 5.1V and no amber if VCC = 4.9V. I Tied !Brick_valid to gnd.

We flashed cube with PX4_FMU_V3_default, and it started pulsing on original CB, but on mine it is flashing amber and being solid green.

#11

You need CubeBlack firmware, not FMUV3. They that.

#12

Can you connect to mission planner on your new carrier via a serial to USB?

The messages tab should then show what’s going on

#13

We have now resolved the issue some time ago, as new cube was working with no problem. We found the other cube broken and have send it to the distributor for replacement/fix, because eventually it stoped booting or whatever and was hanging.

1 Like