Cube Firmware Flashing Ardupilot

Flashing Firmware on the Cube with Ardupilot

I tried to flash my Cube to the latest Arduplane Version and it would not. I used the force bootloader option and it installed chibios and the latest version of Arduplane. The green light that is supposed to be flashhing under the cube no longer flashes. Is this a problem?

Green Light not on is a good thing. I’m not sure what version was last in plane to have green light but the last copter version to have green light was 3.4.6.

Some other things seemed weird to me. Like the chibios being installed and in the telemetry settings, oneofthem had to be set to 2 which, is for Pixhawk instead of 3, which denotes cube. There is really not much information out there for the cube so I am kinda feeling my way around in Mission Planner. Trying to get the RFD900X radio setting worked out next.

What parameter are you setting? 2 vs 3?

For Chibios, you should load the Cube Black firmware

I have it set to 2 for it to work

set what to 2?

I think it was the telemetry setting for pixhawk and cube. Pixhawk was 2 and cube was 3. Mine would only work on 2

the telemetry setting

Please try again. What did you set?

Are you referring to BRDM parameter? Pixhawk should default to 2. Cube to 3.