Cube not detected

#1

Hi All,

I have a cube that has gotten picky. It will not show up in device manager/mission planner. I’ve looked on ardupilot and have seen the same problem come up bt no one has found a fix it seems like.

I have been using USB cable direct into the cube itself and not through the supplied USB adapter/connector.

uninstalled mission planner and reinstalled
tried different USB cables
formatted micro SD card
tried different SD card

I know it’s the cube and not the computer. I have tried many other cubes and they are detected and connect fine.

Can’t even install a different firmware since there’s no COM to select.

I’ve run out of ideas. Has anyone had the same problem and been able to find a solution?

Thanks for the help!

#2

Can you upgrade it? Or won’t detect that?

Have you upgraded mission planner with a clean install to get the drivers?
Are you on Windows 10?

#3

Upgrade it? Like a new firmware?

I’m running 1.3.66. I have not tried 1.3.68 yet. But I have done fresh installs when I did reinstall it.

I am on windows 10.

#4

Fresh install everything and try again.

#5

Could only fresh install mission planner. I’m on 1.3.68 now. I’m still not getting any detection.

The orange leds turn on and stays a solid orange.

#6

RMA it please.

#7

Will do, Thanks!