Cube not getting any RC signals

#1

Hi,
I have a Cube Black and it does not show any signals from the receiver. I have tried both SBUS and PWM inputs but when I look at Ardupilot, Servo Configuration, only the throttle and channel 5 moves. The throttle moves when I use the yaw stick, not the throttle.

What could have caused this? I have tried a totally different cube with the same receiver/transmitter/sensors etc but that worked fine. Its just this one Cube.

Thanks
David K

#2

Verify your rcmap is set up the same as the other cube.

#3

This is sort of what I am wondering. Are you referring to something on the transmitter? why would it work for one cube and not the other?

I have a Taranis X9d+ and an X8R receiver.

#4

Well that too, but I was referring to your parameters on the cube that isn’t working.

#5

this isn’t an old cube from a solo is it?

#6

No, we just purchased it 4 months ago as a Cube black. Im using the carrier board with a new Cube now.

#7

load plane…

then load copter…

give it a clean start, then check it out before adjusting any parameters.

#8

That worked. not sure why…but it also fixed a Pixhawk4 that wasn’t providing power to the SBus port or the PPM port.

thanks
David K

#9

Awesome! That’s the memory equivalent of “turn it off, and back on again “ :slight_smile: