Cube Orange and Here2 on canbus

Has anyone got this to work?

I think ive tried every single combination of parameters I can, and am stuck with no compass or GPS, just flashing blue LEDs on boot.

Running 4.0.3 release AC.

Found this, but its out of date -

Setting NTF_LED_TYPES 231 solves the LED issue, however mag and gps are still dead as door knobs.

SLCAN through MP and UAVCANGui report node ID 125 operational OK hw 2.1 software 1.3.75 F55E1. I tried updating the bootloader and firmware, nil change, I suspect it was already on latest.

Have you set GPS_TYPE=9?
Check COMPASS_TYPEMASK. Uncheck the UAVCAN in masking tab.


Can you try latest master firmware and confirm whether it works?

Are you configuring ur gps while connecting ur setup i.e. autopilot+gps with onboard battery? Moreover, are u in open air… I had several problems initially with here gps… but, now we have made our practice as follows:

  1. The autopilot+gps is power through battery (and not through usb source).
  2. The autopilot has the latest firmware i.e. 4.0 and later…
  3. U r outside the covered area i.e. in the open air/field…
    I hope this would be helpful

Yasir Khizar

did you check the switch on Here2?

I have exactly the same problem as @JacksonUAS with Here2 and Cube orange. Have installed latest MP (deleted and reinstalled). Followed all guidance for bootloader and install of latest firmware onto Here2. Green LEDs post bootloader install. No change in LEDs post new 2.1 firmware install. Have changed all parameters per guidance. When I click Params button in UAVCAN screen - its blank. No compasses showing up. I’m suspicious whether the 2.1 firmware is actually being (re)installed. Although it reports what looks latest version. When I click update in UAVCAN screen and select the downloaded firmware, it shows a progress bar for some time but no change in LEDs to indicate anything happening

Looks like the Here2 firmware is not updating. Hardware is 2.1. Software Version is 1.1.85A98B93. I’ve just tried (again) to reinstall the boot loader. Nothing happens and green LEDs fail to flash as they did the first time

Got sick of screwing around with it, flicked it back to i2c/UART and all is working.

Yes will probably have to do the same. Seems like it is stuck on the boot loader as I suspected. This thread and its links shows we are not the only ones. Problem is the solution seems to require a second cube which is working…

Flash your cube with Plane then try a June 2019 daily build of Copter abs try to flash the Here 2 then

I am on 4.0.3 and I have it working just fine with Cube Orange and Here2.

Change your brd_boot_delay to 7000 and that should work. I originally had it at 5000 which is what I used with my CUAV Neo V2 Pro can gps. However it seems the Here2 needs a little more time to boot up.

I have 100% success rate at 7000.

Thanks @MadRC will give it a go. I can’t find the daily builds for June - could you post a link?
Click on the link and select folder of your board> download .apj file> Flash using custom firmware button on Mission planner.
Note: This link is for Copter Latest Master

SUCCESS! Not sure which was the solution but I installed Plane then reinstalled copter. Changed bad_boot_delay to 7000 and have now successfully installed the Here2 latest firmware. All lights back to normal and compass now visible