Cube Orange Battery Monitor

So i am trying to setup the Cube battery monitor.

When i configure the settings on Batt monitor, I get errors that it “Failed to set” I have been able to get it to work, setting Cube HV power meter and cube orange Hw version then set back to the correct settings ( this isnt working now tho).

Once reading voltage I would get constant Batt1 unhealth warnings.

I have set all the voltages for 3s and 3.5v/c and the voltage is 12.2v shows on HUD but even disabling the time value still gives the error.

Any ideas why I cant configure the power meter and the alarms?

In MissionPlanner go to Setup / Battery Monitor
Check that it looks like this:

Any changes to the “Monitor” “Sensor” or “HW Ver” need you to reboot the flight controller
Default values for voltage divider and Amps per volt should be fine.

Try setting the battery capacity to 0 and removing any other capacity values you might have entered.
Capacity is a very good measurement, but that can come later.

If you have a 3S Lipo these are the correct failsafe and motor scaling values:


MissionPlanner Initial Parameters can give you those and a few more params if you have a copter.

If there appears to be any issue with those values, DO NOT change them → go after the cause of the issue, usually voltage sensing inaccuracy or a battery in owrse condition than what you expected.

Shawn, That’s much different than the User Manual!

I was able to get the settings to work by using those settings in the parameter list. Using the Setup menu was never able to work ( always had failed error)

I was able to setup the voltage alarms and they were triggered incorrectly at first but I was able to resolve it

The batteries are dipping on voltage doing quick maneuvers, so they are at the end of there lives and should be replaced. (I had my doubts but now I can see the data.)

Its unfortunate that the software and settings are not as shown in the manual.

So I came back to this as I verified the Current readings and they are very different that what the cube see’s. (clearly its wrong as motor idle current is 0.0A, when it is infact 2.1A, throttle must be above 10% throttle for current to read above 1A)

I can try setting the Amp/volt but I’m not sure what to set them to. ( The manual states 17)


So tried to calibrate this sensor per the instructions on Ardupilot, but its completely out of wack.

Original value is 39.9
Calculated value was 69
I have even tried 200, this was closer but the current is all over the place (4, then 6 then 8 then 4. other meters show 8A consistent.)

What could be the issue, it seems it is related to some kind of calculation, on startup the Cube is drawing 600mA but Shows 0.01A, way off. Then when armed, the values goes to 0 and shows nothing. ( but meters show 2.1A) is it defective? Why would the current show less when the motors start?


As we mentioned in this discussion the measurements at low currents are not accurate (nor precise) with these basic sorts of current sensors (a shunt/resistor)

and in that thread is a link to the procedure to reliably do the current calibration.

If you need accurate low current measurements there’s a few hall effect style sensors available.

Hi there Shawn,

Understood about the sensor accuracy.

I will have to do some tests to see how inaccurate the sensor is (But from what I can see its anything but ideal) and really only used as an average for consumption, as per the calibration.

I am trying to understand where the low runtime is coming from ( battery or vehicle design) buying another battery to just get another 5 min run time would be unfortunate.