Cube Orange: $CHECK_IMU0_PRESENT Failed


I am trying to load my Cube Orange that I use for development and I get the following message in MavProxy…

I can’t figure out a cause and have tried uploading different firmwares DEV, Beta7, and 4.07 to no avail. I tried resetting the parameters a variety of ways via changing vehicle firmware type or just a normal reset.

It was happily working until I removed it from the carrier board to see if there were good places I could attach a thermocouple for gathering raw baro data. (This was to fix SITLs simulated MS5611 for cold temperatures.) I didn’t find any place for the thermocouple that seemed safe without opening up the cube so I put into back onto the carrier. (Opening the cube didn’t seem like a wise idea.)

I’ve tried reseating the cube onto the carrier a few times as well.

Thanks for your help!


Quick update. Went back 4.07 again and then forward again to Beta then Dev and now I get “IMU1_PRESENT” failed now.

@sidbh Could I per chance get some assistance sometime with this Cube?
It has been sitting in a corner I could use it functional again to so I have one just for development.

I would guess there are a connector inside the Cube disconnected for some reason. Please contact your reseller for RMA.

Hi Alvin,

Yes, this was it. Sid helped me out on Discord with different builds and after discussion he told me I should try opening it up.
I opened it up to find that the connector appeared to be naturally pulling away.