Cube Orange Connection Issues

When the Cube Orange is connected to my computer it says new driver required. That means I can not get it connected with Mission Planner which means I can not flash new firmware to the Cube Orange. The board for now is unusable. Any tips on how to get this board and cube going? I have been using the Cube Black for years now with no issue.

Did you install a recent version of mission planner? It contains the drivers.

Brand new install with a driver clean and reinstall. No effect.

Have you tried to do a firmware load/update? The new Cubes come with nothing installed.

Yes, MP wont recognize a device to flash. It has to be some sort of drive issue but I can’t figure out what.

What shows up in the device manager?

We had the same issue. Check device manager. There we saw that the cube is connected to a specific com port, although it is not named as cube orange. Set this com port in MP and try firmware flashing. In our case it worked. After flashing the com port changed again and we saw Cube orange in the device manager.

This issue has been solved. It was a defective Cube Orange. We ordered a new one and it worked just as it should have.