Cube Orange+ firmware not suitable for board

Hi, I just got a new Cube Orange+ and I cannot update the firmware for it. When I attempt to update the firmware (v4.5.1) using mission planner, I get an error that says “ERROR: Firmware not suitable for this board fw:1063 - board: 11063”. I have another Cube Orange+ that did not have this issue. Can anyone shed some light on why this is and how to get around this? I’d like to keep my cube up to date.

What was the led indication on the side ?
Any device showed up in Device manager ?
Did you try load firmware by “Load customer firmware”

While trying to update the firmware the Cube has a solid orange light on the forward side and a rapidly blinking orange light on the back side of the usb cable.

The device shows up in Device Manager, and I can connect to with with Mission Planner. It’s currently running ArduCopter v4.4.3 and it connects on COM5.

I have tried loading the most recent firmware using the “Load custom firmware” link option on the firmware update page in Mission Planner. I’ve also tried several other firmware options such as v4.4.0 and v4.3.8, as well as the most recent DEV and Beta versions. All instances give me this same firmware suitability error.

Looks like the led indication is showing normally.
Have you try update any firmware on this cube before? Try this firmware and upload it using “Load custom firmware”. If still can’t, might have to try force upload or contact the reseller you purchased the products from.
P.S. This firmware is compiled using ardupilot’s github open source.

I have not been able to update firmware on this Cube Orange+ before. It’s a recent purchase and this is the first time I’ve attempted to do so.

I tried uploading that firmware but still get the same error message.

Can you provide a link or other instruction on the force upload you’re talking about?

Ardupilot Github
Setup the environment here
Download the whole package with

git clone --recursive https://github.com/ArduPilot/ardupilot.git

After cloning the whole package, configure the firmware and try upload it to the board

cd ardupilot
./waf configure --board CubeOrangePlus && ./waf plane --upload

During this step, you might see the same error message as

WARNING: Firmware not suitable for this board ...

Press Ctrl+C to interrupt the process, and then force upload it to the board. (This step could cause damage to your board, try contact the reseller you purchased the products from first)

./Tools/scripts/uploader.py --force build/CubeOrangePlus/bin/arduplane.apj

Please tell me if it works for you or not.

It took me a little bit to get setup, but I followed these instructions. When it tries to upload, I get the same error:
image

Then, when I force the upload, it says it’s successful. However, I cannot connect to the cube with Mission Planner. It gives me the “No Heartbeat Packets Received” message. Mission Planner does see the board type, etc. on COM4:
CubeOrange+ board information

I also still can’t upload new firmware to the cube using Mission Planner (not that I really expected I’d be able to).

What are my next steps? Is there something I can do to connect to the cube properly?

Wait, I forget to ask, did you install the cube driver for windows before doing all this?

This looks like one of the drivers that installs when installing Mission Planner? It looks like it’s installed on my computer already.

Does it show the board type while you’re uploading it?
Take a look at this. It seems to be the same issue you’re facing.

@tcpowers88 Here is my recommendation to resolve this issue. Open the .apj firmware file you have which is a json file and edit the field board_id to be 11063 instead of 1063 and try to flash the .apj file.

For some reason the bootloader on the Cube has got wrong board id. Once you are able to flash the apj, do bootloader update through mission planner through firmware update page after connecting.

You can find the latest firmware from here https://firmware.ardupilot.org/Copter/latest/CubeOrangePlus/arducopter.apj

This seems to be the right direction! I was able to change the board_id and it looks to have flashed successfully. I’m now still not able to connect to the board though. Mission planner will see the board but when I try to connect to the com port (checked number in Device Manager) it times out.

Can I do the bootloader update without connecting?
Thoughts?

@tcpowers88 if my understanding is correct you were able to update firmware but not the bootloader. It is possible that the firmware update didn’t succeed and you are stuck in bootloader, please try updating again with board id modified, see if that works. If you are programming savy, here is a python script that you can use with --force option ardupilot/Tools/scripts/uploader.py at master · ArduPilot/ardupilot · GitHub

It will ignore the board id and forcably update the firmware.