Cube Orange+ giving "Config Error: Failed to update IO firmware"

Hello, I was running PX4 on my cube orange+ with no issues for a few days. Recently I wanted to configure the here 3+ GPS and for that reason I switched to missionplanner. I installed the newest arduplane stable version (V4.5.3) and configured the GPS parameters as per the manual.

When I tried to write the parameters I got an error and when I check messages my board is constantly giving the following error:

Config Error: Failed to update IO firmware
Config Error: fix problem then reboot

I have tried to reboot PX4 on my FC but everytime I connect to QGC I get update cancelled error and it will not let me install PX4 back on the FC and/or change anything. I have tried loading basically every other airframe and version in missionplanner and still no luck. I am on a very tight deadline for a competition could someone please help me out.

QGC does not have the ability to update the bootloader or the IO Firmware.
Use Mission Planner, not QGC and follow the instructions in the wiki to update the bootloader and the IO Firmware.


now, i can load any firmware i want through mission planner, bit it can’t connect !
last month this connection problem was intermittent, how ever i updated the bootloader (boot loader upgrade complete)

no i can’t connect at all :

installed rover then copter
installed px4 then rover than copter

px4 is connecting nicely but without main PWMs outputs