Cube Orange + Mini Carrier Board Can't Upload Firmware

Hi, recently I’ve got my cube orange with mini carrier board, when I tried to upload ardupilot firmware using Mission Planner 1.3.74 build 1.3.7563.27684 it always stuck at connecting progress bar and then it always ended up with the firmware failed to upload and a pop up window saying that “No need to upload, already on the board”. As for the board itself it only shows only one COM Port instead of 2 (the SLCAN port doesn’t show up). Link for documentation Can anyone help me with this issue?

It abounds like your trying to install the firmware you already have. The chances are you don’t have the latest drivers for Mission Planner.

control F in MP and flush the current drivers then download the latest ones from the Mission Planner downloads on Ardupilot.

Sorry for the late reply, I have tried that and my driver is already in the latest version. I have also tried to upload the firmware in the fresh newly installed mission planner on another pc but I got the same issues. On the other hand I also purchased a regular carrier board set of cube orange, and that went alright uploading firmware (on my pc) without issues and it works perfectly well. And I have also tried to swap the cube between those 2 carier boards (mini and regular), reupload the firmware, and still the one that I purchased separately with the mini carrier board had the same issues even after swapping the carrier board, whilst the one that came from the regular carrier board set is working fine on the mini carrier board after flashing the firmware. Is it possible that I have hardware issues? Is there anything to verify that?