CUBE ORANGE - new driver required problem

I can’t instal FW to CUBE because MP didnt see it. I’ve cleanup driver and instal latest MP then cube is visible as PROFI CNCCUBE-New driver required. After instaling latest driver it change to standard serial port.

Try the following, i’ve had the same problem and these seems to solve it.

1- disconnect Cube from USB
2- open mission planner, press CTRL + F
3- in the temp, click driver clean. this will clear all old driver
4- download latest driver from this link
5- install the new driver, and reboot your computer
6- connect your cube to your computer, go to device manager> ports (COM & LPT)
7- you should see Cube Orange Mavlink and Cube Orange SLCAN

I just got new Orange. Want to replace shitty CUAV NORA+. BUT cannot connect to MP. Tried your fixes. Reinstalled Mp . Clean driver. Download and install drivers - still get just 1 COM device and driver update required message. Really irritated. If anyone has suggestions will try, otherwise Amazon gets this back Monday and the hunt for decent AP continues…
How can CubePilot sell this POS without proper instructions on how to configure with MP ?

have you put a firmware on it? the driver doesnt really matter in this case

My solution, after hours of fighting with ‘new driver required’ :

  1. Install QGroundControl
  2. Flash the newest version of Ardupilot
  3. Connect with MP without any problem

Hope this will help someone

Finally got the driver to work. Reinstalled MP. Did clean drivers. Then installed firmware. Magically worked!

1 Like

Thanks for the steps, I have tried the steps but unfortunately I am still seeing only one COM port for Cube Orange.