Cube Orange+ Setup w/ ArduRover

Hi there!
So I am currently working on a project trying to build a rover using the Cube Orange+ w/ ArduRover firmware with Skid Steering.

I am having lots of trouble with setting up the motors.
Initially I was trying to use:
Motor: Flipsky Outrunner Brushless DC Motor Battle hardened 7070 110KV 4200W
ESC: FLIPSKY Dual Mini FSESC6.7 Pro 140A base on VESC6.6 With Aluminum Anodized Heat Sink

I’ve had 0 luck with this ESC, I’ve tried using it under several different configurations without the cube and couldn’t get it working at all so I’ve given up on this. As for motor I was able to get this working with a different configuration not including the cube.

Anywho, I went through a long troubleshooting process and just tried setting up the Cube Orange+ with a friends drone who’s running a PixHawk with ArduCopter, so I flashed ArduCopter onto my cube and got it working fine with his setup in minutes. I then flashed the ArduRover back on and could not get the motors working. They would respond when powering on as an indicator I guess, so there is some form of signal to them but could not get them working properly. I used an oscilloscope to check the signals, I had throttle left assigned to 1 and throttle right assigned to 2. There was a signal but there was no change to the signal in accordance with the throttle activity.

I then flashed ArduRover onto my friends PixHawk, on this I was able to assign his servos to throttle left and throttle right and got it working with the motor test. For some reason his setup works fine with ArduCopter or ArduRover on the PixHawk, but on the Cube+ only ArduCopter worked for us.

This is my first time doing a project like this and I am at a complete loss; I have no idea what I am doing wrong with the Cube or what I have to get things working. I have to get this done by the end of the month and was hoping to implement the object avoidance however at this point I just want any manual control function through the cube

Any guidance would be significantly appreciated!

Thank you.

I ran into a similar issue w/ ArduRover and found that I needed to arm the cube before I had access to throttle. (Steering was available while disarmed).

Are you trying to operate in manual mode while armed or disarmed?