Cube Orange Startup Fail URGENT!

Hi, I’ve been using Pixhawk(cube orange) for several months on my dual Heli. But since last two weeks, I’m facing a startup problem with it.

  • Sometimes when I power the Pixhawk, it doesn’t bootup normally. It keeps booting up by itself again and again (until I disconnect the power manually).
  • When booting repeatedly, the orange led stops for a fraction of second after the musical startup tone, then the whole process repeats.
  • The first musical startup tone is the normal one as in the link. But after that the tone is little different. It doesn’t match with any sound in Pixhawk sound database , it might be a combination of the normal startup tone or some fail tone (because its kind of similar to startup tone).
  • In total there are two types of sounds that it makes, both the sounds start with same music as startup sound, just the last part is different.
    1. last part is long tone on low pitch
    2. last part is short tone with one high pitch and one low pitch sound.

I have added two sample videos for Pixhawk startup fail

  1. Video 1
  2. Video 2

What if you power it from USB only?

i think you might need to try a few things, unplug all the external devices apart from power, and does it boot? then slowerly add things back to test if it still boots

@xfacta It happens sometimes with USB too.

I have already tried this method, I removed all the external connection and found that device was booting properly. then I started plugging other devices and PWM connections one by one.

  • I did that twice and ones I found the safety switch is creating the problem. I changed it but didn’t work.
  • In other test I found that RFD 900 might be the issue. But the problem persist sometimes even after removing the RFD module.
    I also tried to het the logs, I changed logging settings from arming to bootup. But it is still not creating any log.
    If it starts normally there is no problem with the cube’s performance till now. However that startup error keeps popping up.
    I tried to put a new cube under the same conditions to recreate the problem, its not happening. the new cube also had the same FW, same params & the same connection. So I think there is something related to this cube only.

Well, now you have suggested it, I’ll do it again a few more times to pin down any one of the external device which might be creating this problem.

Try flashing a different firmware version say airplane then switch back to copter…see if that works…

Bootloader update ?

I tried it, didn’t work at all.

After updating the bootloader, the problem didn’t occur for like 90% of the start ups. It was booting fine almost all the time, but sometimes that problem occurred.
After updating the bootloader, I changed FW to Copter 4.1.4 and came back to the original one that I am using. The startup problem is coming almost every time I’m trying to start the cube.

Till now following points about its behavior I have collected:

  • The start up fail problem is like a loop, it keeps rebooting itself with sounds similar to the startup sound I mentioned in the first message. here
  • It doesn’t happens when no connector is connected to the cube.
  • one pattern I see is, if I press the safety switch (blinking to solid red light) before the startup sound, it boots up normally, and it works fine.
  • If it went into the startup fail loop, and I press the safety switch (blinking to solid red light), the loop breaks with normal startup sound, and it works fine after it.

Unplug the the main cube and plug back in and then try.

Hi @Satish_Chaudhary , thanks for the reply.
Could you please elucidate more on how unplugging and plugging again will help this case.

Thank you

I had a cube orange when I left unused for about 1 month I had Same problem of starting or booting the when I tried to boot it didn’t start so what I did is it neither connect to the PC or anywhere else.
So I just separated the main cube from the standard carrier board when when you actually see at the down there are 4 long screws which are probably M2 size.
You can try just unscrewing all those 4 screws connected to the main cube then unplug the main cube
Then plug back in with perfect click sound.Then screw tightly those screws again.Just give it a try

Hi @Satish_Chaudhary
Thanks for a good explanation.
I did, what you suggested, I removed the cube and placed it again on the carrier board. But, the problem is still there.

When the Cube keeps rebooting itself, do its COM ports show up in device manager?

Not Sure, I have changed the cube. I’ll connect the same again and check.