CubeOrange + can't connect to mission planner


my CubeOrange plus can’t connect to mission planner, i can upload any firmware no issues, but to connect afterward, after 30s will give me : no heartbeat received.

i went throught this tutorial :

replaced my usb cable, updated my mission planner, installed the latest firmware …

same problem !! Pls help !!

Are you choosing the right device?
Check on the device manager to make sure you’re choosing the right COM.
Better to take a screenshot of your issue.

As above and also is it a new Cube+?


sorry for the late reply !
here’s some pictures.

i’m using cube orange plus, and mission planner is recognizing automatically.

flashing any firmware normally, but to connect … no way.


If you are using windows 11 you sometimes need to just reboot your PC/Laptop.

hi, i restarted my laptop many times.
note that nothing is connected to it yet.
i tried 4 new different cables…

i saw a tutorial about secure firmware : i don’t know if this topic is related to what i’m facing…

i don’t know what to do, my EFT416P drone project is paused for now.


i want to add :

the firmware installation is always successful and i always see “upload done” but today i fixed the speaker/usb that comes within it’s package, i don’t hear any sound after firmware installation or after plugging it in.

is that normal ?

yes, it’s a new cube orange plus.

pls check the attached pictures.


today i installed the safety switch and speaker/usb cable.

i went with QGroundcontrol installing CubeOrangePlus firmware :

QGroundControl can upgrade the firmware on Pixhawk devices, SiK Radios and PX4 Flow Smart Cameras.

All QGroundControl connections to vehicles must be disconnected prior to firmware upgrade.

Please unplug your Pixhawk and/or Radio from USB.

Plug in your device via USB to start firmware upgrade.

Found device: CubePilot

Connected to bootloader:

Version: 5

Board ID: 1063

Flash size: 1966080

Downloading firmware…


Download complete


Firmware file missing parameter_xml_size key

Firmware file missing airframe_xml_size key

Successfully decompressed image

Erasing previous program…

Erase complete

Programming new version…

Program complete

Verifying program…

Verify complete

Rebooting board

Upgrade complete

NO MUSICAL TONE, is this normal ? i left it like 10 minutes after the firmware upgrade finished.

kindly check this video :

Solved !

open qgroundcontrol,
flash PX4,
close qground,
open mission planner,
flash arducopter or any model…

thanks anyways.