Cubie Yellow

Hi Guys
I get brand new Cubie Yellow. I uploaded the firmware ( copter 3.6.9) but I have problem
Mission Planner says Initialising APM and thats all, in QGC i see message Check BRD_TYPE: Unable to detect board type.
I wonder If its problem with hardware or MP and QGC ???

Can yo post a screenshot?
And you will need latest master BTW

3.7 minimum

I try 3.6.10-rc1but nothing change10-rc1

If try 3.7 dev firmware
after flashing I cant connect to Cube. After power on led is orange and I try to connect after few seconds i get message no hearbit

Are you using the latest drivers? Are you sure you are on the right port?

Try loading plane then copter to reset everything

If I load 3.6.9 or 3.6.1-rc1 I can connect to Cube but get message i terminal:
Check BRD_TYPE …Unable to detect the borad type
BRD_TYPE is set to 0 (auto)
If I load latest 3.7 software I cant even connect to Cube…

Now Im traying load plane firmware and then copter but nothig change still get
Check BRD_TYPE: unable to detect board: sensor failure: unable to detect board type

OK problem solved I remove driver i install again Now I have two ports
Cube Yellow Mavlink (COM68) and Cube Yellow SLCAN (COM66)
Now I can connect to COM68
I load latest 3.7 dev firmware
Many Thx Philp

No worries!

So on cube yellow and cube orange you get SLCAN and Mavlink at the same time now :slight_smile:


Hey @philip,
Just a small question. Will yellow cube be compatible with spektreworks carrier board? I mean, is it being tested on that too?
Thank you

All cubes run on all carrier boards