Decimal Separator Issue

Good Evening,

Just noticed a strange thing in mission planner when I load a parameter set offline (not connected to FC).

All the parameters which were for sure set WITH decimal separator in the FC, show up WITHOUT separator when loading the parameter set offline.

E.g. 4,5 (correct value) shows as 45 when loading the set offline. This is the case with all parameters with decimal separation.

Something wrong with the latest version of mission planner? I am on 1.3.74. same issue with the latest beta version.

Any advise? This could be potentially dangerous?

Thanks

Sven

I have tried on my Mission Planner 1.3.74.1 build 1.3.7755.3560

I can’t recreate your problem. You may try to re-install your Mission Planner

Thanks Alvin. Same problem after re-installing Mission Planner.

It could maybe be related to the region depending on which separator is used in that region (point or comma). My colleague has the same issue on his computer. We are located in Germany.

Basically I wanted to compare 2 parameter sets offline. I load the first set and it shows up wrong (without separator). I open then the second set for comparison and that one shows up correctly. That way a comparison is not possible.

Strange bug.

Maybe you can try this param file:
test.param (17.7 KB)

I saved this from my computer. You may try to load this to your Mission Planner, so that we could figure out if the “save” part or “load” part is having issue.

You can also open the param file as excel or txt, so that you can verify if the raw values are correctly saved.

Thanks Alvin. I have tested it with your „test.param“ file with the following result:

Opening your original test parameter set in excel shows the parameters correctly WITH decimal separators.

When opening the file in MP it shows up incorrect WITHOUT decimal separator.

Saving the file then leads to a corrupted version of your test parameter set. Opening the saved version then in excel shows that the saving process has eliminated all decimal separators.

See pictures attached.

I would be tempted to adjust Windows regional settings to avoid this issue completely. And also remove any thousands separator to avoid confusion. It seems very few regions use the comma as a decimal separator.
At least until there’s a fix.

Yes, Shawn. I will check with changing from comma to dot in the Windows regional settings.

However, the map below suggests that it would be worth implementing a proper fix in Mission planner :wink: