Disable GCS failsafe when in Manual Mode

I had an unfortunate crash this week where on final approach with my rc plane I had a GCS failsafe that caused the plane to go to RTL mode. I was at a low airspeed and low altitude and the plane went into a 45 degree turn and attempted to climb, resulting in a stall that eventually crashed the plane. Is there a way to prevent the GCS failsafe long event from changing modes when I am in manual mode? @philip

I don’t use it myself, I’m not aware of another option

I think this is also a fault of ArduPlane “stall prevention” not being very robust. Even if you had to preform a late go around and did a quick roll at landing speed the aircraft would have crashed. The crash would have been less likely to happen if getting to ARSPD_FBW_MIN was put as a higher priority than making the turn. Yes the stall prevention system does limit roll angles, but scaling of those angles is only documented in the comments of that section of code.

Set FS_GCS_ENABL: to 3 so it is only active in Auto mode

1 Like

Thanks Craig. That is exactly what I was looking for.