While trying to sort out some problems " bad compass health" error. I am trying to set the EK3_IMU_MASK ==7 but with Mission Planner 1.3.70 build 1.3.7426.10.530 on a black cube I can’t find that parameter? EK2_IMU_MASK is there but the only listing for EK3 are EK3_ENABLE, EK3_GPS_TYPE and EK3_VELNE_M_NSE
note just checked the latest beta 1.3.7429.11453 and I can only see EK3_ENABLE.

Why are you using the EK3 is there a specific reason ?

I am getting the same error messages as this forum post mentions.


One of the suggestions was

[Let’s Live

Mar 16

Change these parameters

Set AHRS_EKF_TYPE to 3 to use the EKF3 instead of EKF2 or EKF1.
Set EK3_IMU_MASK to 1(default) to use the first IMU in EKF3.
Set EK2_ENABLE to 0 to disable the EKF2 because we enable EKF3.

I did the above and the problem was solved.]


After some more research into my problem it seems that I have been in too much of a rush to press the safety switch. Just powered on 12 times and have found if I press the arming switch too quickly after the 2nd single beep I don’t get green leds and a GPS lock. If I wait a few more seconds and make sure I get green leds then I have no arming problems or compass errors. So hopefully it is just operator error.

No it wasn’t the switch that is the problem. The Here GPS is showing 16 satellites in Mission Planner but pressing the button doesn’t always produce a green led. Sometimes it does straight away, other times I might try 10 times and still not get a green led. I am operating in a rural area with clear view of the sky. Have GPS Type selected as a uBlox after moving it from auto.