ESC Calibration

Hi all, having an issue with Copter 4.2.1 on Cube Orange where I can no longer calibrate my ESCs through the usual method of throttle up, power on, power off, power on. The ESCs don’t engage during the calibration and I always get the pre-arm error of “Check MOT_PWM_MIN/MAX”. Setting MOT_PWM_MIN to 1000 and _MAX to 2000 I can then run a calibration by the above method, but one motor always seems to be out of sync/doesn’t start to spin until mid throttle whereas all others spin at arming speed when armed. It’s a different motor out of sync each time as well, not the same motor. Never used to have to set MOT_PWM_MIN/MAX as it was taken care of during the ESC calibration from the controller. Any thoughts? I have done this build multiple times and have multiple aircraft now with the same problem.

Issue has been found/solved. My default parameter file for my setup needed to be updated with a few extra changes that I have previously missed.