Ethernet companion computer not returning data


I have a companion computer attached at to my herelink (default gateway:

I have tried to create an RTSP stream from my companion computer, but was unsuccessful. I see the incoming request to my RTSP server, but it is almost like no data ever gets back to my controller.

I tried to spin up a webserver on my companion computer, and hit it from my herelink controller. I was able to successfully hit it, but nothing was returned.

Here is a video of me explaining this a bit more:

It seems like a routing issue I am missing. Any advice would be helpful, thank you!

I am also getting heavy packet loss when attempting to ping radios.

I am hardwired (ethernet) from my RPI to the radio at So, I am wondering why I am getting such high packet loss

Have tried modifying route paths, have tried updating all firmware. Have tried all different types of gateways. I can adb into the airunit and ping my onboard computer with ease, but I am still struggling to ping all other devices from my onboard computer.

Any insight would be appreciated

Now that I am looking at it…
I am on the airunit pinging the onboard computer. I am getting packet loss. Not as much as going from onboard computer to airunut, but I am still getting packet loss

I wonder if something is messed up with my ethernet connector

I resoldered a new ethernet connector with no change in result.

It appears we had to have a flight controller plugged into the UART port in order to get this to work.
It appears that we are now not having packet loss. I am curious if mavlink-router was attempting to connect, and when it couldnt it would fail and restart. and that was causing issues somehow.

We actually set the ip to and things seem to be flowing. we arent 100% sure we know how the issue was fixed, but we are investigating