Extremely high RC latency (FrSky R9/Orange Cube)

I am not sure if this is a Cube Orange problem, or a radio problem. Hopefully somebody can help. I am closing in on a new copter build. I am using a Taranis radio with the R9 Module and receiver and an Orange Cube. The receiver is connected to the KORE carrier board RC pins. I first noticed the extremely high (like 1 or 2 seconds) latency when doing the radio calibration. When I tried spinning up the motors (no propellers) I get the latency there as well. There is also a very high amount of latency when changing flight modes. Obviously I have not tried to fly this model. What could be causing this amount of latency? Thanks.

What frequency are you using? Is there any source of interference around?

Hello Alvin. Thank you for responding. I am using a Taranis radio with the R9module and receiver. It’s 900mhz. I get the same result in my house, in my yard, at a park or out in the desert, so I don’t think I am getting interference. I was able to improve a bit today by changing the channel output to 8 down from 16, but there is still an incredible amount of latency. This may very well be a radio problem, but I am stumped. Are there any FC parameters that are kind of obscure that might affect the speed at which Cube Orange might react to RC input? I am using a brand new Cube Orange on a Kore carrier board. Thanks again for the reply.

I don’t think there are any options to delay the input in Ardupilot nor Cube.
You may go to Mission Planner > check the “Tuning” box under the map > double click the graph > check “chXin” to verify if the delay was coming before or after entering the Cube,

You may also modify a telem cable and change the serialX_protocol to verify whether it is a problem specific to RCIN port.