Facing issues with DISARMING ON LANDING

(ZABBIE) #1

Hi,
I am using Pixhawk 2.1 with Firmware version 3.6.9, I went out to test my tethered hexacopter yesterday, I calibrated each and everything. I have tested my other hexa frames but this time I faced a couple of very strange behaviour that has never happened to me ever before.
I faced the following problem:

  1. I made a two-point auto mission first one was take off and another one was to hold the position. Both waypoints had the same altitude. I switched the copter on AUTO mode then suddenly after attaining the provided altitude the ‘‘IMU did the YAW RE-Alignment’’ in the air and did the yaw of about 60 degrees which has never happened in the air.
    Can anyone explain why did this happen?

2)The other issue I faced was during the landing, I tried to land the copter in two ways one was through RTL and another was in loiter mode.
In RTL the copter came down with high speed and landed. After landing, the motors did not slow down at all instead it was trying to attain more speed, I tried to disarm motors using RC, it did not disarm it and ultimately flipped.
Pixhawk should have detected the crash and stopped the motors but motors did not stop at all I had to disconnect the power source to stop the motors from running.

The same thing happened when I tried to land using LOITER mode but this time the crash was detected and motors were stopped.
After going through the log the only abnormal thing I noticed was GPS HDop.
Here is the log from the flight. LOG

My entire concern is why did copter did the yaw movement in the air and most important part is why it did not disarm the motors after landing.

#2

The yaw is caused by magnetic effects in the ground normally, and is corrected in flight

(curt carroll) #3

@Zabbie
Your GPS sv# was cut in 1/2 when you came down. Was this your flying site or is the gps randomized?
If it was your flying site then the building caused lots of multipath signals and loss of lock. I assume you were not flying next to this tall building but still the loss of lock happened as you came down probably blocking reception. This is a really strange GPS glitch, it was not detected, It was not caused by a voltage drop. This points me to your GPS antenna not the GPS receiver. What GPS are you using?

(Christopher Wighton) #4

Hey Guys, I’m having the same issue with one of my systems as well. Updated to 3.6.10 and running a Here GPS. System flew perfectly, apart from not disarming when landing.
I have been able to disarm using telemetry, but if left too long the system does flip.

About to swap the GPS over and try that but would love a confirmed solution if anyone has been able to work through it.