Fixing Bad State/Bricked Cube Orange Plus

Hello,

I was trying to add OpenDroneID firmware to a Cube Orange Plus following this tutorial: How to add RemoteID to ArduPilot Systems (youtube.com)

This tutorial is for the Cube Orange, but there was no specific firmware and bootloader for the Cube Orange Plus. I followed the tutorial and instead uploaded the OpenDroneID firmware and bootloader for the Cube Orange. After uploading the new firmware, the IMU0 errored, but the Cube Orange Plus continued to respond. Then, I uploaded the new bootloader according to the instructions and rebooted the Cube Orange Plus.

The Cube Orange Plus was no longer detected by my computer. The Cube LED did not do its normal boot up cycle but instead stayed orange without flashing as it normally would. I also plugged in the speaker which just continually blared and did not play the normal boot up sound.

I opened Mission Planner and tried to upload a bootloader but got this error:

After reading online material, I discovered two possible solutions to reset and upload a new bootloader: 1. Break open the Cube Orange Plus and manually short the boot pin to reset the internal STM32 or 2. Use a Black Magic Probe (https://www.adafruit.com/product/3839) to reset the Cube through the DFU Debug port on the ADS-B Carrier Board.

I opted to try the second option and got the Black Magic Probe. I connected the board via the JTAG interface and adapter shown below:

The BlackMagic Probe is (COM3 and COM4, COM3 is for the connection to the Cube). Then I tried powering the board both through a micro-USB and through the BlackMagic Probe and scanning for either a JTAG and SWD scan to find the STM32, but despite having a detected target voltage of 3.3V, the board scan failed and never found the Cube Orange Plus’s STM32 chip.

Any ideas on how to fix this Cube Orange Plus? Is it bricked? If so, is there a way to upload a new bootloader without breaking open the Cube Orange Plus itself?