Flashing firmware on AIR unit not possible after latest upgrade

I was able to update my Herelink GCS via the Android settings----System update menu. However while i use the flasherwinzip file for flashing the update to my Airlink, the USB driver is not recognized on my PC ( Win 10) . I have also tried using the Google USB driver . Still not detecting the Air link unit !!

Have you powered the air unit with 7-12V?

Also, what error message did it show when running the flasher with console?

1 Like

Yes , it is powered by 11v .
the flash win program finds the airlink device as ADB usb device… i am using the win 10 (64bit version) , The program simply exits with the attached error!adb interface|690x389

Did you extract the flasher.exe from zip?

1 Like

Yes of course…Should we disconnect the Sbus and UART connection from the CUBE while this firmware update on the Airlink operation is being carried out .

On another desktop PC , I am getting the attached error on my USB port
( " Unknown USB device ( Device descriptor request failed ) "

Does this mean anything …

Try the followings:

  1. Check if the air unit is showing up in device manager (as “ADB interface”)

  2. Try “adb kill-server” before running the flasher
    If the message
    ‘adb’ is not recognized as an internal or external command,
    operable program or batch file.
    shows up, use http://zadig.akeo.ie/ to reinstall the driver on adb device to WINUSB lsusb-win32

  3. Press and hold the pairing button until unit powered up.
    Wait for 1-2 seconds and insert the USB.
    Hold down the pairing button.
    Wait for 5-10 seconds.
    Try the flasher again.

1 Like

How do you do a ADB kill-server ?

In a console. Eg: powershell/cmd

1 Like

OK…It seems to have flashed everything well . Communication with Airlink and Auto pilot ( Orange CUBE) is working well .