Forgot to plug in my air unit antenna

So yup, I did that. Now there’s no connection. Any way to fix it? I’m pretty sure I know the answer : (

Can I know more details about the “no connection” ?
Did you lose HDMI, Sbus , telemetry date or unable to pair?
May I know the hardware and firmware version of your controller and airunit ?

I forgot to attach the antennas on the air unit. To make things worse, I bumped the tx power with adb. So I’m pretty sure the output amp is fried with no load. Wonder if they can be repaired?

Hi Shaun, please send this unit to your local dealer for RMA.

While I doing a video for an RMA, I was told to try a few things and record the result. Starting with a FW update. Of course, not possible over wifi. Tried the Windows updater, but it kept failing at splitting the directory. Got rid of any versions of the windows updater and downloaded it again and it worked. So tried pairing with my new controller and though it would pair, the connections lasted only seconds. Tried pairing with my older V1.0 TX and got a notification of a firmware mismatch. To clarify, the V1.0 TX is on beta channel and the 1.1 isn’t. The old TX allowed me to push a wifi firmware update which gets the airunit operational. So a couple of questions. How can you change whether you’re on beta or stable in the TX settings? And while connected I still get complete dropouts as shown in the picture. I only get these every minute of so. But I’ve had previous issues out in the field with RC failsafe triggering.

Something to worry about?

How can you change whether you’re on beta or stable in the TX settings?
No you cannot, the firmware has noting to do with this frequency section.
May I know the firmware version of your controller and airunit?