Geo tagging of Images

What is the best way to do Geo Tagging of Images when we do Aerial mapping
What are the best Geotagging module to Geotag Images in Air during flight

Drotag seems to have issues with arducopter. I remember that @rmackay9, worked on it with the manufacturer but i dont know if it is solved.
You can also have a look at Entire modules, one of them auto-tags the pictures

Yes, as @Julien says I originally had problems with the Drotag but I worked with one of their developers and we got it working. It should work fine as long as the latest firmware from Drotag is used but I’m a little unsure how Drotag releases their software. I used a version sent directly to me by the developer and I think/hope that all new Drotags are shipping with the new version.

I also have an Entire module that I plan to test.

If you find any problems getting either module to work with AP feel free to ping me although normally the best place to find me is in the ArduPilot Copter-4.0 and Rover-4.0 categories.

AP’s wiki page on the subject is here:

I have also Drotag I am using it , now my latlong fields are empty in Images , there is 0,0,0
Can you share Drotag Image , One sent by developer yesterday that is not working

One of my client had the same kind of issue. Some pictures were fully tagged, a part was half tagged (sometimes with crazy values) and the rest was not tagged.
I know he sent back his module to drotag team, but have no news if it is fixed or not.

I think I’ll ping the Drotag developers and see if I can get them to pop-up here.

@chandrahas, could you tell us the camera you’re using and whether it’s connected using the hotshoe? Also I think it would be good to double check that your setup matches what we have on the AP wiki?

…and do you see the “Comp 2” showing up in the mavlink inspector?

Guys, I’d like to move this discussion to the ArduPilot forum if that’s OK. It’s not specific to the cube and I’m having some problems providing links in this forum.

1 Like


You may have already seen but one of the developers over at Drotag has posted the latest Drotag firmware on the AP forum linked above. He’s also offering to look at the autopilot logs to help figure out why it’s not working.