GNSS NMEA Input impossible

Hello,
I like input NMEA sentence on GPS1 port.

My GNSS send RTK position, it’s a rover who received correction by 4G modem by connection to NTRIP Caster or by radio modem when corrections are transmet by my GNSS Base.

Setup:
GPS_TYPE: 5
GPS_SBP_LOGMASK: -256 (I don’t understand this option and I don’t test -1 or 0)
GPS_GNSS_MODE: 0
GPS_RATE_MS: 200
SERIAL3_PROTOCOL: 5
SERIAL3_BAUD: 38

My GNSS output data by DB9 RS232 femelle , I build a cable with DB9 male to GPS1 connector, Pin2 DB9 to Pin2 GPS1, Pin3 DB9 to Pin3 GPS1 and Pin5 DB9 to Pin8 GPS1. I test another cable, Pin2 DB9 to Pin3 GPS1, Pin3 DB9 to Pin2 GPS1 and Pin5 DB9 to Pin8 GPS1.

Has anyone made this kind of connection before? I can find no information about it!
Is there a documentation that details the frames and parameters for using the NMEA data of a GNSS RTK for navigation(Boats) and the log of the positions of a measurement (sonar in my case).

Thanks
Ludovic

rs232 is wrong voltage level
Cube requires ttl serial, not rs232 serial, you need a converter

Thanks a lot for the information, I basically thought that just put RX on TX and TX on RX. I’ll order a converter and go back on the operation.
A simple SERIAL to USB converter don’t do that?
Sorry for my English, I’m French.

Hello,
I come back for explain my solution.
I have order a low cost converter by Amazon, but it’s not work after some test.
Finaly I buy a Sparfun converter PRT-08780, and it’s OK I can use my Survey GNSS!
Thanks

I am using rtk since some weeks. Tersus GNSS . I can see RTK FIX on MP screen . Do you Change any parameters of pixhawk for high accuracy flight ?

Hello,
For the moment I can’t doing test in France, my project is a boat.
On my boat I have a rover GNSS who receive correction by his radio from a base install on know point.

Rover send NMEA GGA, RMC and VTG at 5Hz,115200 baud to Pixhawk. I don’t know if RMC and VTG are use by Pixhawk, no docs for explain what NMEA message are importante for navigation.

Without navigation test I have juste change EK2_ALT_SOURCE at 2 for use altitude from GNSS and no barometer, it’s important for my project to have ellipsoid height for referencing my bathymetrie on french system.

After first test, if I change parameter I come back here.

what brand is your gps, nmea is a very bad protocol, as it doesn’t contain alot of information the autopilot needs

For me it’s a survey GNSS, T300+ by Comnav technology.
Now, with NMEA it’s OK but I have problem for setup position Offset for my GNSS, IMU and Sonar.
Can you help me with this draw?


What are the good offset setup?

Thanks

the comnav binary protocol is supported. assuming it hasn’t changed.
it is the same as novatel. set GPS_TYPE to 15 aka NOVA

I think it’s an error, it’s not ComNav marine but Comnav technology (SinoGNSS compagny) http://www.comnavtech.com/