GPS and ARHS differ problem

(darren waters ) #1

20191030_124547

I am having a hard time getting the rover to accept mode change reporting GPS and ARHS difference ranging from 12m to 70m

I have tried to mask internal compass because of a high metal frame but no joy

3dr Pixhawk 2. 1 blue cube

#2

Have you calibrated your compass? Is the orientation correct? Can you mount your compass up higher?

(darren waters ) #3

Yes has been calibrated and the variance is coming and going. Unfortunately due to the metal content.

Is ARHS the heading i see thos can be rotated

Can i use just 1 compasses if i use compass mask i tried a few different check boxes what are the actual numbers for the internal compasses so i can mask these.

Do i need a compass can gps work out direction?

#4

You only need one compass, mask out the crap

(darren waters ) #5

Hello

Thanks i have masked the internal compasses, however i still struggle to mask the internal compasses form communicating and igniting the variance. Also of i wiggle the cube it displays compass movements on the HUD but i am using an extenal unit.