Gyros Inconsistent after update to 3.6.8

I have octocopter with Cube Black which was bought in September 2018. I was flying with it without any problems with firmwaqre 3.5.7 nuttix. Now I changed the firmware to 3.6.8 chibiOS and I changed also

INS_USE == 1 
INS_USE2 == 1 
INS_USE3 == 0


INS_USE == 1
INS_USE2 == 1
INS_USE3 == 1  

and one problem appear. During first start after longer period:

  1. Cube starting normally and showing that everything is ok green leds on Here GPS
  2. but after few minutes it’s showing “Gyros inconsisntent” in Mission Planner and leds are yellow and I can’t take off.
  3. It happens only after longer period when I don’t use multirotor, during first start.
  4. If I turn off and turn on multirotor again there is no problems and copter flying ok.

Anyone have any idea why this “Gyros Inconsistent” message is showing ? Maybe that’s connected with heating IMU ? Why I don’t have this message during second third and next starts ???
Here you can see me log:

@Norimbo Can you get a log for some extended duration. There seems to be an unusually high Gyro Drift in the log for second IMU, I’d like to check if it gets stable once the stable temperature is reached. The log was stopped just before the temperature was reached.

Thanks for investigation!

Yes off course:
cold start log
second start just after switch off switch on battery

If the first log is still to short I can wait even 20 minutes and create another…just write here an info.

You can monitor raw temp and watch for when temperatures reach what BRD_IMU_TARGTEMP= Is reached. You should always pre-heat cube to that temp and only arm after that anyway.

But the problem is that I am checking that in home temperature and during first boot it never reach good temperature and never is ready to take off leds are yellow forever.

Sorry if you miss understand my last comment. The first part of my comment was to answer your question: “how do I know I have logged long enough to know if it reached temp?” The second part is just a common thing that is over looked by most people.

Ok so things are getting more complicated :frowning:
My arming button on HereGPS sometimes locks when I am trying to turn it on or off so I changed:
but that means that Arming is turned on to early ? before good temperature of IMU is reached ? and that’s why I get this “gyros inconsistent” message ?

@Norimbo Thanks for sharing the details, based on your logs I have come to the conclusion, that there needs to be a bit more smarter way of doing temperature control. Please stand-by for a test firmware, I will share it with you.


@hdtechk how can I check (monitor) in MissionPlanner what is current temperature of IMU ? I was searching in “Status” tab but didn’t found.

Maybe that’s RAW_TEMP ?

I changed BRD_SAFETYENABLE: to 1 but that didn’t change anything still during first cold boot gyro2 has totally different values even if I wait 10 or 15 minutes. If I just reconnect battery everything is ok.

Yes it raw_temp

I always do a reboot after reaching temp. Before flights. What’s most important though is what @sidbh and @philip think. They are the ones that know

@sidbh is preparing a test firmware for making this process much better.

for now, warm up, and reboot.

Ok thanks for info

Please try this firmware and report back if the issue is fixed. The PR has been placed . Please note that this is not a stable release firmware, it built on top of current master. Only use for testing the said issue.

1 Like

I updated cube with this firmware and for now I know that this firmware makes my Cube and HereGPS 1 much more sensitive for magnetic interference. I still get “Bed Compass Health” in the places where in 3.6.8 there was no problems (in hause and on balcony). I changed position of the copter during first recorded log and didn’t move it during recording second log (it was on balcony). I hope that’s this message (Bed Compass Health") showing because that’s beta firmware.

I didn’t noticed that “Gyros Inconsistent” message during cold boot so I hope this problem is solved now.
During second boot I get “Error position variance” maybe because of testing on the balcony ??

If you need I can go somewhere on open area (not in the house) if this will help with new firmware.

I am sorry but I tested again and “Gyros Inconsistent” still exist during first boot. Please look at this log:

Per your logs it seems, you only received 2samples of MAG data and it suddenly stops reading mags afterwards. Since there is no mag the EKF fails and hence the bias calculation and Attitude estimate. That’s why you are getting all those issues. I am looking into this issue, meanwhile it would be great if you can reset your parameters and try again.

@ sidbh Do you want me to reset all settings in my copter so lost all parameters like acc calibration mag calibration esc calibration etc. or I can do it different way ? Sorry but I didn’t reset my parameters earlier.