HDMI 1 stream not working: Receive timeout. HDMI 2 streams fine

Hi,

Summary:
I was working on connecting my camera system to herelink and it was all working fine and after a small incident, I noticed that HDMI 1 is not streaming anymore. However, HDMI 2 streams fine.

The incident:
So I tested my camera system with herelink and it was streaming well on HDMI 1. So after I mounted the camera on my drone, I connected the “HDMI to micro HDMI” cable from the camera to herelink and powered on the drone system (The camera was supposed to be powered from the 6S balance port that time, since I was only testing and later planned to power camera directly from the power distribution board as well).

So after I powered on the drone system (not the camera, only the drone system), I connected Solex with the FC and went to the video screen. Everything seemed fine.

So I thought to power on the camera (which was already connected to powered herelink with HDMI cable) from the 6S balance port to get the stream, but I made a little mistake. I connected the positive wire first and noticed that the camera turned on without connecting the ground. I quickly disconnected. Later I concluded that the camera got its ground from the HDMI cable through herelink which was already powered on and it didn’t seem much of an issue to me since everything was powered from the same battery only.

Now I powered on the camera again, but this time I connected the ground first and then the positive wire. The camera turned on but alas, no stream on Solex. I retried but still no stream and I get the error message: "Unable to stream video: Receive timeout"

But when I try plugging in the camera to HDMI 2 and switch the camera from Solex, the stream is working fine.

I also tried reflashing both ground and air units, but still HDMI1 is unable to stream.

Have I damaged my herelink. If yes, then how? Also, if HDMI1 is damaged and only HDMI2 is streaming, then is there any other damage done to the system which could impact range or any performance?

Please help in clarifying.

I am using Pixhawk Cube Orange with Copter 4.0.7.

I have also attached a wiring diagram of the incident which happened.

@philip @Alvin @MadRC

Thanks,
Divyanshu

Sounds like the HDMI port got a spike, technically all the grounds are linked so it should have got ground form the shielded connection on the HDMI but anything could have happened.

It’s probably killed the HDMI transceiver on that port. I would not have expected it to affect anything else of it appears to be working fine.

As Ian said, I suspect the damage is localised to the HDMI traciever.

You could send it back for repair, but if you only need the one video feed, leaving it on HDMI2 will work fine

1 Like