HELP! Can't load FW in latest Cube

#1

Hi all,
i’m facing a problem here, i just received a black cube. It behaves different from previous i had: it seems to not boot with a firmware, so MP and QGC do not recognize it, neither in the flash firmware sections of both. It appears as CubeBlack-BL in the com ports list of Manage Peripheals window (after i did i zadig change driver - otherwise it appeared under “USB peripeals” tree with no Com port added.
I cannot flash any FW on it. Tried also Betaflight method (as suggested in copter docs in chibiOS section).
I’ve read somewhere (i can’t find link thou) that latest Cubes came with no fw inside, but i can’t find how to flash it first time.
Any info apreciated, thanks!

EDIT: it seems related to the fact manifacturer changed USB_PRODUCT to 0x1001 but i can’t find a solution to it yet

#2

Have you downloaded the latest MSI installer for mission planner? It comes packaged with new drivers for the cube. (Using the update button in mission planner is not acceptable)

As far as im aware cubes no longer come flashed with any firmware and require the user to set it up.

1 Like
#3

The cube blacks do seem to behave a little differently. What i did is just plugged it in and went into the MP firmware page and chose what i wanted to upload to it. I found that it wont show up in the com list whem you plug it in, but they may not mean its not being detected. I think it kust means that nothing has been loaded onto it. I also have tried clearing the sd card but i dont know if that step even helps and its a pain to remove so i dont recommend but its something you can try, and then try uploading arducopter ore whatever you ar trying to get on the cube.

#4

Do not remove the SDCard! The SD card has nothing to do with firmware.

Load mission planner from the MSI.

I suggest keeping up to date with the announcements here…

#5

It was a faulty cube. I took another one from same shipment and i managed to flash it with no problem. I Will return it to My reseller

1 Like