Help! Unstable in loiter mode when take off!


I’ve already built the quadcopter drone using Cube Plus and here 3 + run the Arducopter v4.4.4 firmware
The drone looks fine when I take off in stabilize mode and after that, I switch to loiter mode,
drone is very stable.

But to easy for the newbie drone pilot to take off, I want to take off at loiter mode to make the stable for my drone.

So I switch to loiter mode to take off and my copter may be unstable and can flip. ( GPS is 3D lock).
Now, I need advice to fix the copter can take off in loiter mode.

Here are my logs: copter logs file – Google Drive


1 Like

Have you auto-tuned the drone?

I am sure you have read this Loiter Mode — Copter documentation

1 Like

Thank you for your reply,

I already tuned my drone manual and don’t have auto-tune, the copter has worked well in stabilize mode and loiter mode. So I think no need to auto-tune.

Yep, I have read the Loiter Mode — Copter documentation
I have the 3D lock and a good HDOP below 1. (mean 0.8)
but I can’t take off in loiter mode. Any ideal?

The tuning is quite good for manual - good work.
I noticed the HDOP was not great, and you can see on the map the GPS position and IMU-calculated position diverges more than expected.

Tell us more detail about your copter, such as

  • battery cells and type
  • prop size
  • ESCs

The reason I ask is because there are many parameters at default values, and I think we can do a lot better. And the harmonic notch filter wont be working.

Start with these changes until we know more:


and possibly GPS_GNSS_MODE,5 instead of 65 even though 65 is usually good.
If that large building has a lot of solar panels (it looks like it does) then I find them to be very reflective of GPS signals and you might get a better result being a little further away from it, at least for testing.

1 Like

I also meant to say:
I didnt see any very bad behaviour from Loiter. I suspect the GPS wandering position is giving you trouble at take off, and in big copters this can cause a tip-over or even the copter moving horizontally fast and hitting things - so be careful!
I would suggest take off in AltHold mode and get a couple of meters altitude.
Or enable the Fence - then you wont be able to arm until there is a good 3D fix and Home can be set.

1 Like

Hi Xfacta, thank you for your advice!

My copter uses a 5008 tiger motor and 16-inch prop running 40alpha esc
Using cube orange plus with here 3 GPS.

I’m currently using an external compass from here 3 GPS. when I power on an aircraft, I see the wrong altitude. The aircraft is on the ground, but I see the altitude in QGround is 2m? is this wrong?

I do not think my large copter can take off in loiter mode.

When I take off in loiter mode after switching to loiter mode, the copter works perfectly.

But I take off in loiter mode, the aircraft is unstable and I can’t take off.

I just want to take off in loiter mode stable to a newbie pilot can take off copter like DJI drone.

Now are the logs for the first flight today! I’d take off in stabilize mode and after that switch to loiter mode

Also, because of the newly built drone. I don’t change too much pagram, just tune the manual.
In your answer before, Can I change this pagram to better performance right? I will try it.

Thank you so much for your help!

OK, set these for the Alpha ESCs


and you will need to recheck your MOT_SPIN_ARM and MOT_SPIN_MIN using MissionPlanner motor test. Set MOT_SPIN_ARM to the lowest value where all motors start reliably, for example 0.11.
Then add +0.03 and set MOT_SPIN_MIN , for example 0.14

It’s OK to use AltHold instead of Stabilise to take off, it is much more “in control”, until Loiter is sorted out.
But it’s always good to practice in Stabilise anyway, one day you may need it.

What battery do you have?

Set all the other parameters that I already specified, they are mostly data-gathering and some slight improvements. Let’s see the log after a new test flight with all the adjusted parameters.


Hello Shawn,

Thank you so much for the solution,

After changing the MOT_ param as you advise, I can take off the loiter mode perfectly,
The altitude may be fixed. The copter looks fine now.

But I need some tune pagram to good position hold.

Also, I’m using the lithium battery with 9600mah 6s. I going to update Tatulipo 6s 16000mah for a longer flight time.

I will post logs in tomorrow.

What do you mean

Is it Lipo or Li Ion? Semi-solid state or anything special?
Which battery are you planning on getting?

Did you do all the other parameters I mentioned to gather data and aid tuning?

Head over to ecalc, put in your components and see the copter goes with your existing battery, then change to the new battery and see what that does for motor temperature and flight time.
A bigger battery may not give more flight time if it is too big.

1 Like

Hi Shawn,

This exactly is Lithium Ion Battery.
I going to update to Tatu Lipo battery for a longer flight time, Thank you for the advice about ECALC, I will consider it.

Also, I have set the pagram as you advised me, everything is just fine now:
Here are the logs: