Help with Cube Orange Com ports in windows

I just purchased a new Cube Orange and am trying to upload Ardupilot firmware for the first time using Mission Planner on Windows 11. Currently in the Windows device manager, the Cube Orange appears simply as a generic serial port under COM3. I understand it needs to appear as two separate ports, one of which is the MAVlink. I assume that once I can get it to show up correctly in the device manager I will easily be able to connect and flash firmware.

Some braindead things I’ve ruled out.

  • USB cable: it’s the one that came with the cube orange
  • USB port: tried multiple

Things I’ve tried:

  • reinstalling mission planner stable release
  • uninstalling drivers
  • reinstalling driver.msi
  • rebooting computer
  • combinations of the above

Trying to get my project off the ground and I am new to the Ardupilot / Cube orange world. Any help appreciated!

I believe I fixed it. I roughly followed another post on here and installed QGC in addition to mission planner. I installed firmware using QGC (though I am not sure that was necessary) and then went back to Mission Planner. That did the trick. However, for some reason in Windows 11 the device manager still shows only a single port. Mission Planner however, shows the MAVlink port (listed under a different name) and SLscan port.

The first firmware install will only show one port as only the bootloader is running