Here 2 GPS No Satellite Connection

(Taegan Obermeyer-Loder) #1

I work for Indiana State University in the Unmanned Systems department and I am working with a build group designing a quad copter UAV with the Pixhawk Cube, and the Here 2 GPS. In both QGroundControl and Mission Planner it shows that the GPS is connected to the Pixhawk but I am never able to get any satellites. When I am testing it I am testing it outside in an open area and I usually give it a couple minutes to startup but it still doesn’t get any. The GPS has lights on it that turn on when the Pixhawk turns on and the safety button works in the software. Is there a fix to this?

(Rich) #2

Taegen - Welcome to the group!

Which Cube are you using and how are you connecting the GPS, I2C/serial or CAN?

(Taegan Obermeyer-Loder) #3

Hello,

We are using the standard black Pixhawk Cube from Proficnc. The GPS we have connected to the GPS port with the cable that it came with.

Sincerely,

Taegan

(Jake) #4

If you bought your Here2 recently it comes setup in CAN mode, so if you swapped out the CAN cable for the GPS/i2c cable there is also a switch inside the GPS puck that needs to be switched to i2c mode. I’ve plugged in a few Here pucks to the GPS port on the 2.1 without flipping the switch first and they light up but get no GPS lock so that’s my best guess as to the issue you’re having here.

1 Like
(Taegan Obermeyer-Loder) #5

I just tried switching the switch in the GPS and now am getting different lights on the GPS module but still no satellites. Could it be a setting in the Pixhawk?

(Jake) #6

Check that GPS_TYPE is set to one, I believe setting it to two should work as well as it is a ublox GPS, pretty sure I have mine set to one and it works fine. Shouldn’t need to be changed unless you’ve messed with it earlier, also make sure you’re testing for satellites outside and away from any large buildings. You can also check that SERIAL3_PROTOCOL is set to GPS, again don’t think these would be set to anything else unless you’ve changed them before.

(Taegan Obermeyer-Loder) #7

When looking for these parameters I could not find them in QGroundControl. I have tried Mission Planner but it fails to connect although QGroundControl does fine. Is this a parameter in Mission Planner only? Thanks for your help

(Ian ) #8

Tbh we need a lot more information.

If this is a Here 2 we need to first establish if your using CAN or Serial for the connection.

You need to set the switch inside to either but you many need to update the firmware to use Serial and you will need to use CAN to do this.

Tbh I would just setup with CAN and I posted a video on this on YouTube showing the process.

(Taegan Obermeyer-Loder) #9

Hello,

I just checked out your video although I am unable to see the parameters that I have to change in order to get the GPS working with CAN instead of I2C. I have attached a screenshot of the issue I am having. I am looking for the CAN_P1_DRIVER but it is not showing.

EDIT: I also have swapped to the CAN cable and flipped the switch to the CAN mode as well.

EDIT 2: I also do have the advanced parameters enabled in Mission Planner in the Planner tab under Layout

EDIT 3: I am using MAVLINK to connect to the aircraft instead of a direct USB as I cannot get Mission Planner to connect with a USB only with the MAVLINK radio.

(Ian ) #10

What version of Ardupilot you using ?

(Taegan Obermeyer-Loder) #11

Version 1.3.68 build 1.3.7105.26478

EDIT: One thing to mention, I checked all of the parameters that I had to change from your video about the GPS and I cannot find any of them in Mission Planner or QGroundControl

(Ian ) #12

That’s mission planner what are the actual firmware on the controller, it’s shown when you connect with mission planner.

on the flight data screen goto the messages tab. Firmware version is written there.

I think your on old firmware and need to update.

(Taegan Obermeyer-Loder) #13

Hello,

When I looked at the Messages tab I do not see the version. I am using Mavlink since plugging the Pixhawk directly in with USB does not connect on Mission Planner. I have attached a screenshot showing the issue.

(Ian ) #14

You have some other issues going on that need solving first.

1: update the drivers for mission planner from here
http://firmware.ardupilot.org/Tools/MissionPlanner/driver.msi

2: get the connection for USB working, if it’s the same after the update try another computer to see if your USB port is damaged.

3: I think your on an old version of Ardu and need to update for CAN.

(Taegan Obermeyer-Loder) #15

Hello,

The driver update worked and got the USB working. When I went to the “Install Firmware” tab of Mission Planner it went to this loading bar and never finished loading. Is this supposed to happen?

Sincerely,

Taegan!