Here+ RTK Setup

Has anyone got this working with the HereLink?

Using wifi hotspot and UDP connection to laptop running MP, with Here+ plugged in, wasnt getting any corrections forwarded to the aircraft (wasnt really expecting to either to be fair, but figured it was worth a go)

That should work fine.
Maybe some screenshots and logs etc?

It’s working with a direct connection ok?

Havent tried direct connection yet, dont have the OTG cables to hook it up. Will try find something. Does the android build have drivers for the M8P?

Via UDP all looks normal for an M8P rtk setup, however doesnt seem to be any corrections forwarded to the aircraft as GPS status remains at 3 (3D gps) and doesnt jump to float/fixed.

There is nothing in android that has anything to do with this.

If your mission planner is set up correctly, and communication with the cube is right, then it should work, if it’s not, we will need to look at the mavlink forwarding system in HereLink, it may be the issue.


Im talking plugging the Here+ base station straight into the micro USB on the Herelink, I assume it has ublox drivers baked in? Havent tried, do not have cables.

Ive played with a few M8P standard setups with a conventional MP groundstation, did exactly the same but UDP connection, no bueno.

No, that won’t work, there is no intention for that to work.

1 Like

Will investigate why udp is misbehaving

1 Like

With this setup, can I then adjust the parameters of the cube on the PC / notebook without a USB connection?

You will need the computer anyway. The RTK data go through
RTK base -> computer -> wifi -> Herelink controller -> Herelink air unit -> autopilot

But you can adjust the autopilot parameter from Herelink without having USB connection between them

@Alvin Thanks for that information! - Never tryed it out and i am flashed how easy it is to set up everything without having a cable connection. :slight_smile: