Herelink air Unit 1.1 Failing OTA update


I have a herelink v1 controller bought in April 2021, I have fully updated it to the latest version. I also have the original v1 air unit that works well and has been updated through OTA to the latest version.

I am trying to do the same to the 1.1 unit and it keeps getting stuck during the “transfer to airunit” stage.


  • Also the whole airunit tab seems buggy and it doesn’t always download the fw information and I have to switch between tabs multiple times to get it to load the info.
  • Sometimes after pressing “download air firmware” the two other options are greyd out forcing me to switch tabs in order for the buttons to eventually be displayed. Not sure if relevant just trying to give as much info as possible.
  • The reason why I am trying to update it for the last 2 days is because this airunit gives very buggy video through HDMI and we assume its because of the FW mismach.

I have also updated the airunit through the windows app just in case.

What else I tried:

  1. Restarting the Controller + airunit multiple times
  2. Factory resetting the controller
  3. Holding down the airunit bind/reset button while booting
  4. Pressing “Update this app” It downloads and then just quits the app
  5. “Update OTA APP” same as above, no idea if it actually does something

Please let me know what else I can try. So far the experience we are having with Herelink is pretty bad and we are trying to incorporate in our products but it’s making us think twice.


please use the “update this app” button

also when you say 1.1 unit

are you talking both sides are 1.1?

Thanks for your reply Michael, as stated in the initial post I had tried that several times. The ground unit is v1 and the air unit v1.1.

After two full days I managed to get it to update ! And work properly!

The only way to do this was reflashing the ground unit with the flasher and then setting it up for BETA updates.

Hopefully you figure out why this is happening so other people don’t experience this again.

Please let me know if there is anything I can do to help.

How did you get your TX on the Beta channel? My V1.0 system is on the latest beta, but my new 1.1 is on stable. The V1.1 is actually nuts. Turns off during flights and drops the hotspot to the laptop.

I did a factory reset and then when prompted to download the software update I clicked on bottom left I believe if said sign up for BETA. Then I did the normal fw update process for the airunit.

I did the factory phone reset and still no option for BETA. This controller is almost impossible to get into fastboot mode, so that may be an issue. If this thing does one more OTA update to the same thing, I’ll be looking for my framing hammer lol!

Pressing power + D button won’t do it? You can also plug in the rc to a PC and use ADB to force it into fastboot as well as perform a full reset. Also did you try reflashing the firmware using the flasher app ?

Using the power and D button is hit and miss, but mostly miss. But even with the unit not in fast boot, the flasher app will still find the device and install the firmware. This could be a problem though and maybe why it always forces a ota update to stable. I didn’t realize you can force the Herelink into fastboot with adb. What’s the command?

I’m not sure what you mean by “forces ota update to stable”.

However if you’re flashing the fw successfully that means the flasher is able to put it into fastboot and write the fw.