Herelink & Air Unit Fail to Connect

Hi,

I have a Here link setup which I cannot get to bind to the Air unit. The controller is on the latest firmware version and the air unit is powered off a bench power supply set on 10V.

There are two issues I’m currently experiencing:

  1. Air Unit pairs to the controller and immediately un-pairs.

The binding steps are as follows:

  • Holding down the ‘Pair/Reset’ until LED 2 flashes green
  • Hit ‘Pair’ on the controller
  • LED 2 should go solid green

What happens for me is that as soon as LED 2 goes solid green, it then changes back to solid orange. This is also reflected in the controller settings page as it provides no information in the air unit tab. See the two videos below of what happens:

AirUnit Pairing Video
Controller Pairing Video

  1. Air Unit fails to update the firmware.

I have downloaded and un-zipped the ‘flasher_win’ program for Windows. I run the program, power up the Air Unit, plug the USB cable in and as soon as the flasher detects the air unit, it immediately throws a traceback error too quick for me to read and closes the flasher. I’ve tried this powered up normally and in bootloader mode to the same end.

Any suggestions or help with this would be greatly appreciated!

please download the latest “flasher_win” app
also try installing the drivers as listed here

Thanks for the reply, Michael. The driver was able to fix the firmware update issue I saw. Apologies, I did read that section but thought it only applied to the controller.

After updating the Air Unit to the latest firmware I am still unable to pair them together. The Air Unit still exhibits the same issue.

Still haven’t found a solution to this issue. The latest firmware on both devices, tried turning the wifi off and tried binding in an area with less wireless noise with no luck. Any help would be great!

can you confirm the version installed on both sides?
also how new is the unit?

I don’t know the actual version number of the Air unit, I just used the latest ‘flasher_win’ on the cube pilot website that was linked above. The controller says it is on Android 7.1.2 and up to date.

In terms of the age of the system, it was only purchased earlier this year. I don’t have an exact date sorry.

ok, so that tells me its a 1.0 unit, and flasher_win should be loading the November 2021 firmware on both sides.

you say it appears to link while pairing, then fails. if you goto the frequency screen and look at hopping, and bandwidth, what do the defaults say?

This is the screen I get after I re-pair the air unit whilst it connects momentarily. None of the other settings load in the air unit page though.

Okay quick update, it looks to be paired and working as expected now.

Going off the Determine Controller upgrade method in the documentation I was using the OTA method for updating the system saying it was all up to date. I’ve just used the ‘Update Via PC’ method for the controller which worked with the only downside of wiping the existing apps I had on there but at least it works now.

Thanks for your help trying to debug the issue, Michael!