Herelink Air Unit firmware update problem

Im trying to update Herelink Air Unit firmware to latest beta with flasher_mac - but it wont launch correctly (OSX 10.14).

Looking for DeviceTraceback (most recent call last):
File “flasher/”, line 260, in
File “flasher/”, line 143, in detect_until_found
File “flasher/”, line 239, in detect_unit
File “site-packages/adb-1.3.0-py3.7.egg/adb/”, line 140, in ConnectDevice
File “site-packages/adb-1.3.0-py3.7.egg/adb/”, line 221, in FindAndOpen
File “site-packages/adb-1.3.0-py3.7.egg/adb/”, line 128, in Open
File “site-packages/usb1/”, line 1309, in claimInterface
File “site-packages/usb1/”, line 133, in mayRaiseUSBError
File “site-packages/usb1/”, line 125, in raiseUSBError
usb1.USBErrorAccess: LIBUSB_ERROR_ACCESS [-3]
[2531] Failed to execute script flasher

Herelink Air Unit itself is shown in macbook lsusb command output:
Bus 020 Device 009: ID 2717:ff28 2717 Telepathy Air Serial: xxxxxxxx

Im also able to adb into Air Unit:
adb shell
$ df
Filesystem 1K-blocks Used Available Use% Mounted on
rootfs 401480 9304 392176 3% /
tmpfs 404776 168 404608 1% /dev
tmpfs 404776 0 404776 0% /mnt
tmpfs 404776 12 404764 1% /tmp
/dev/block/mmcblk0p15 507848 377084 120280 76% /system
/dev/block/mmcblk0p17 1015704 42424 935928 5% /data
/dev/block/mmcblk0p16 253920 148 248532 1% /cache
/dev/block/mmcblk0p9 12016 48 11644 1% /persist
/dev/block/mmcblk0p4 2939 537 2117 21% /amt
/dev/block/mmcblk0p18 1560576 3036 1557540 1% /sdcard

It seems that flasher_mac is not able to detect herelink air unit properly for some reason.
Please help @sidbh

Tried also different macbook with older MacOSX (10.13) - does not work either, a bit different error:

/Users/macbook/Downloads/flasher_mac ; exit;

Traceback (most recent call last):

File “site-packages/PyInstaller/loader/rthooks/”, line 13, in

File “/Users/sidbh/.pyenv/versions/3.7.6/Python.framework/Versions/3.7/lib/python3.7/site-packages/PyInstaller/loader/”, line 623, in exec_module

File “site-packages/pkg_resources/”, line 33, in

File “/Users/sidbh/.pyenv/versions/3.7.6/Python.framework/Versions/3.7/lib/python3.7/site-packages/PyInstaller/loader/”, line 623, in exec_module

File “”, line 116, in

File “/Users/sidbh/.pyenv/versions/3.7.6/Python.framework/Versions/3.7/lib/python3.7/site-packages/PyInstaller/loader/”, line 623, in exec_module

File “”, line 153, in

ImportError: dlopen(/var/folders/2r/77y5vl454_j5jjgyq5ncsr8r0000gp/T/_MEIsr9J31/, 2): Symbol not found: ____chkstk_darwin

Referenced from: /var/folders/2r/77y5vl454_j5jjgyq5ncsr8r0000gp/T/_MEIsr9J31/ (which was built for Mac OS X 10.15)

Expected in: /usr/lib/libSystem.B.dylib

in /var/folders/2r/77y5vl454_j5jjgyq5ncsr8r0000gp/T/_MEIsr9J31/

[3584] Failed to execute script pyi_rth_pkgres


Saving session…

…copying shared history…

…saving history…truncating history files…


Deleting expired sessions…30 completed.

[Process completed]

Does it mean that flasher_mac requires MacOSX 10.15 - @sidbh?

Got it finally flashed with flasher_win on another laptop. Windows flasher behaved also quite unstable - it performed random exits for the first 3 times I run it - 4th time it started the fw download and pulled it through.

Was that a Windows 10 PC 64

Yes - win10.

@frame You were getting the error because you had adb server running as well at the same time, you need to do adb kill-server before be able to run the flasher_mac program.

Thank you for the explanation @sidbh.